Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > Accessory switch won't work

Join Wrangler Forum Today


Thread: Accessory switch won't work Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-28-2012 12:33 AM
sangathor Thought of the fuse, couldn't find it under the hood. I assume it's prob behind the dash. Thanks for the info on removing the dash.
03-27-2012 10:42 AM
Casotakar1229 yea, I'd check the fuse...mine blew up inside the breaker for my aux lights. installed new one and good to go.
03-27-2012 08:23 AM
Peepers Have you checked the fuse for the lights? If they are after market, there should be an inline fuse somewhere, probably near the battery. If there is one and its blown, replace it. If it blows again, there is probably a short somewhere and you will have to chase all the wires individually until you find the problem.

Assuming you have a TJ like in your profile picture, you can pry out the vent over the defroster, you should feel a couple of snap locations that just push in and pop out, then there will be 2 screws underneith there. If you have an ash tray, there will be a third screw behind there. Then just pry the whole face off.
03-27-2012 08:16 AM
sangathor Is this thing on??



03-25-2012 03:16 AM
sangathor
Accessory switch won't work

Ok, this is probably stupid, but I'm a new Wrangler owner and by no means an electrician.

I bought my Wrangler with aftermarket fog lights. They look like some cheap autozone brand. There is a switch for them on my dash, next to the ashtray. The lights worked fine when I got the jeep. When I would turn on the fog lights the switch would light up orange and the light on the switch would go off when I turned the lights off. All good.

Then suddenly the lights no longer go on and the switch won't light up anymore. All the wiring under the hood still looks intact. But I can't figure out how to remove the switch or the accessory panel to check behind there.

My questions are:
  1. How do I remove the accessory panel?
  2. Any suggestions on where to look and what to look for on why the lights won't turn on?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:22 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC