Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > lights on ac/heater temp blower panel

Join Wrangler Forum Today


Thread: lights on ac/heater temp blower panel Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-04-2012 10:46 PM
MrBee Do the voltmeter next.... I'll wait here while you try. hehe
04-02-2012 08:09 PM
krhodes Couldn't find my voltmeter - I just pulled the bulbs and wired them to a 9volt battery - all checked our fine - still not working in dash though
03-29-2012 02:51 PM
Shelby427 Yep, do an actual voltage check. Test light needed or a voltmeter.
See if you have power and ground at the circuit board, where the bulbs connect.
If so, then check the sockets and bulbs.

If not, start with a wiring diagram and find out where you are loosing the power/ground.

But, at least from your description it sounds like you have bulbs that one after another gave up.
03-29-2012 02:05 AM
MrBee I think the bulbs are dead. How do you know the bulbs are functional?
03-18-2012 05:37 PM
krhodes
lights on ac/heater temp blower panel

I've had my 05 TJ for a little over a year now - when I bought it the light on the fan control intermittently went in and out - the out for good - then my temp knob light - now none (on that control panel)

I pulled the panel but all bulbs are still functional - doubting the little lights wouldn't have a fuse of their own - I checked anyways - and all fuses functional - when I had the panel out I checked all connections to ensure proper seating

all the controls function - just cant see them in the dark - my only guess now is maybe the actual circuit board is malfunctioning - which if that's the case I'm sure its not worth replacing just for the lights -

thought??

tl:dr - ac control panels wont light up anymore - tried everything I can think of to make work - nada

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC