Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > clicking noise in front end...HELP

Join Wrangler Forum Today


Thread: clicking noise in front end...HELP Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-13-2013 12:47 AM
jepptone
1989 jeep yj/ noise when starting out and follows to high speed, changed motor mounts

07-08-2011 05:34 AM
TnDz TJ
Quote:
Originally Posted by Annathan View Post
Found my clicking problem... it is a worn bushing on the pivot arm of the shifter (2whell drive, 4 wheel drive hi, 4 wheel drive low shifter).
if I hold the shift lever when starting it does not make the sound so I looked underneath and there is was, completely worn out. I can move it with my hand and it sounds exactly the same.

GREAT!! Determination pays off! Now you can enjoy your weekend!!!!
07-08-2011 12:51 AM
cocdieselkev
Fixed It

Crawled under my jeep tightened down the track bar where it connects to the to the passenger side front axle side. No more clicking when i turned the wheel and its been good ever since.
02-18-2011 12:33 PM
Annathan Found my clicking problem... it is a worn bushing on the pivot arm of the shifter (2whell drive, 4 wheel drive hi, 4 wheel drive low shifter).
if I hold the shift lever when starting it does not make the sound so I looked underneath and there is was, completely worn out. I can move it with my hand and it sounds exactly the same.
02-11-2011 03:07 PM
coyote99 Another point about the body lift and Im not sure about the laws where you are, but in Virginia above a 3" body lift is illegal because of the danger involved
02-11-2011 02:09 PM
Annathan Any idea's???? I don't want something to break but I also don't want to bring it to a dealer to have it looked at.

Any help will be appreciated
02-08-2011 07:18 PM
Redwrangler8 My jeep does the samething but it's when I take off. It squeaks repeated then when I get around 10 mph it stops. Any suggestions?
02-08-2011 03:59 PM
Annathan I also have a clicking it only happens when I take off. If I start our real slow it does not happen but if I accelerate quickly it clicks a couple of times maybe 6 - 10 times. Once I get up to about 7 or 8 miles an hour the clicking stops.
Any idea's ?
01-27-2011 05:54 PM
cocdieselkev About the clicking, I was having a similar problem. When i would turn my wheel i would get a clicking sound or at low speeds in tunrs i would get a clicking sound too. I checked all my u joints they looked fine. i climbed under my jeep when someone was turning the wheel for me and it was my track bar clicking. I just found it tonight so i havne't fixed it yet but i'm pretty sure i need to tighten it down or replace to bushing. so if u haven't checked that it may be it. especially if have replaced the u joints and wheel bearings it worth a look. all i had to do to figure it out was put my had on the track bar and follow the vibration of the click down the the lower track bar bolt. when i cupped my hand around it and applied pressure there was no click and then when i let pressure off it started clicking again. hope this helps.
05-05-2008 12:20 PM
1BLKJP Take a look at your frame and see if your tire is rubbing on it when you turn?
05-04-2008 10:01 PM
ygohome I had a couple of different "clicking" "popping" sounds in the past with my jeep.

One of them sounded like it was from the front passanger side. It is very difficult to discern exactly where a sounds is originating from. In this case it was actually comming from the rear drivers corner. lol. My hearing is pretty good but I couldve sworn it was from the front passanger.

Anyway, it was one of the wheel studs on the rear axle. I have alloy usa shafts and they have two different bolt hole patterns drilled. My studs are "screwed" in (not pressed in) to the axle. One of the studs was a few turns loose and was contacting the drum internals inside the rotor hat (rubicons came with rotors in the back but instide the hat it has drums for the emergency brake).


THe other noise took me forever to track down. Was happeneing since thanksgiving last year and I tryied everything to trace it. Checked rear driveline, front driveshaft, ujoint, unit bearings, even the tcase chain. Seemed to only happen on take off and on steep hill climbs. Turned out to be the front ring gear had a chipped tooth. Very small chip but it was on the tourque part of the ring so when I gave it throttle or climbed a hill in 4lo it would sound like a ratchet, very fast clicking/popping.

Other sounds I remember comming from the rear sway bar bushing cuz they were too tight. The links bolts were so tight that when I'd back down out of the driveway they give just a little and "POP" free.

in other words, it could be anything.
05-04-2008 08:52 PM
jherrin215 I wanna see pics of it too. I have never seen a 4"BL on a TJ
05-04-2008 07:50 PM
dustin well i just replaced both wheel bearing hub assemblies and it still makes the noise! i guess i'll just drive it until something breaks.
04-28-2008 06:32 PM
dustin ok thanks, i'll look into a 2" lift. the 4" was on it when i got it. i'll put some pics on here when i figure out how.
04-27-2008 07:24 PM
Triple88a I'd recomend a 2" body lift. Many will recomend a 1" body lift however a 2" bl will replace everything u needed with ur 4" bl while a 1" will not so you will not know what to do. With 1" bl you will end up replacing the pucks and maybe the radiator brackets but thats it and you will have parts from the 4" bl left over and thats not good. a 2" bl will replace everything from the 4" bl.
04-27-2008 07:18 PM
dustin yeah it does it in 4 hi too. its like a click click click click repeatedly. i got new wheelbearings and hubs comin in the mail, so i'll see if that was the problem or not. i think the bearings didnt have any grease in them. do you think that might make that type of noise? also which suspension lift do you recommend if i were to remove the body lift?
04-27-2008 12:30 PM
Triple88a 4" body lift not only looks UGLY but its also unsafe.

Also for the clicking, when you turn does it happen repeatedly or just once or twice?

Click click click click click...?

also is it not a rattle it's a click?

This might not help but you never know. Put it in 4 hi and "take off" then. Does it still make noise?
04-27-2008 10:43 AM
dustin it happens when i take off. if i drive in a circle it does it, or if i take off hard turning sharp. why would you take the body lift out?
04-20-2008 06:38 PM
Triple88a i would rip that 4" BL right out.

anyhow when does the clicking happen? stop and have some one turn the wheels while you listen for the clicking.
04-20-2008 06:06 PM
MR.CLIFFORD can you take pictures of your 4" body lift?
04-20-2008 04:28 PM
dustin
clicking noise in front end...HELP

I have a 98 wrangler 4.0. it has a 4" body lift and 32x11.50s. when i turn the wheels and accelerate there is a clicking sound coming from the driver side front of the jeep. i replaced the u joints on both side of the axle, and it didn't stop. i thought it might be the splines on the outer axle or maybe the wheelbearing hub assembly, but it doesnt look worn! i have no idea what else it could be. any input would be greatly appreciated! thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:45 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC