Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Michigan Jeep Forum > 2003 Wrangler sport trans slips

Join Wrangler Forum Today


Thread: 2003 Wrangler sport trans slips Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-01-2012 10:38 AM
phittie1100 I would run it over to the local auto parts store and let them run a quick scan to see which trouble code has popped. But slipping is usually not a good thing.

As Jeeperman pointed out, an aftermarket cooler and temp gauge is worth the money in the long run, whether your problem is terminal (this time) or not.
04-01-2012 08:33 AM
jeeperman Your plan is the only one that I know of.... The transmissions in the 2003-2011 Wranglers are the weak link in the drive train. It's very important to keep them cool, a lot of people use aftermarket auxiliary trans coolers. Good luck, hopefully clean fluid takes care of your slippage.
03-31-2012 12:21 PM
Brad Becker
2003 Wrangler sport trans slips

I have 56k on the jeep,just bought 2 days ago,drove home fine no problems,went for a drive in the rain on I-94 about 15 miles into my trip I notice the tach jumping than the loss of power as the trans slipped,the dash light came on as well,I pulled of the freeway and checked trans oil level,it was full so I limped back home, back road style,still notice the slippage on the way home.
I will change the oil and filter today,any other ideas from you good folks???

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:42 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC