Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > need help now please! trying to finish!

Join Wrangler Forum Today


Thread: need help now please! trying to finish! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-04-2012 10:36 PM
tcate23-WRANGLER
Quote:
Originally Posted by GoldenSahara00 View Post
No prob get it back on?
yeah and test drive went good! post bl/mml, thanks again man
04-04-2012 09:35 PM
GoldenSahara00 No prob get it back on?
04-04-2012 08:40 PM
tcate23-WRANGLER
Quote:
Originally Posted by GoldenSahara00 View Post
The front is in the bottom of the pic. As you can see there is a slight taper.
thank you so much man!
04-04-2012 08:37 PM
tcate23-WRANGLER
Quote:
Originally Posted by GoldenSahara00 View Post
Well if your holes are lined up then it should be right. Uh I'm gona see if I have a pic of the skid so I can tell you front fro back. But as long as the holes line up and the tcase mount is through and started te bolts then you should be fine.
thanks man and a picture would be great. You really came through for me!!
04-04-2012 08:35 PM
GoldenSahara00 The front is in the bottom of the pic. As you can see there is a slight taper.
04-04-2012 08:34 PM
GoldenSahara00
Quote:
Originally Posted by tcate23-WRANGLER

thanks golden, yes when the skid was off it was supported by the bell housing. The 4 nuts are on but when i bolt the frame bolts in, it lifts up the transmission.

Like I had the skid on a hydraulic jack and was supported by that while i was trying to get it on. I then put the bolts in the right side frame and went to do the left and couldnt without jacking the skid up more.
Well if your holes are lined up then it should be right. Uh I'm gona see if I have a pic of the skid so I can tell you front fro back. But as long as the holes line up and the tcase mount is through and started te bolts then you should be fine.
04-04-2012 08:31 PM
tcate23-WRANGLER
Quote:
Originally Posted by GoldenSahara00 View Post
Are your studs for tcase mount through the skid? You should have had your transmission supported at the bell housing while the skid was off. If you didn't then it probably lowered so your fine then.
thanks golden, yes when the skid was off it was supported by the bell housing. The 4 nuts are on but when i bolt the frame bolts in, it lifts up the transmission.

Like I had the skid on a hydraulic jack and was supported by that while i was trying to get it on. I then put the bolts in the right side frame and went to do the left and couldnt without jacking the skid up more.
04-04-2012 08:26 PM
GoldenSahara00 Are your studs for tcase mount through the skid? You should have had your transmission supported at the bell housing while the skid was off. If you didn't then it probably lowered so your fine then.
04-04-2012 08:24 PM
tcate23-WRANGLER
need help now please! trying to finish!

hey guys, trying to put my stock skid plate back on. Should i have to jack it up to get it back on or do i have it backwards?

The bolts are going in but it looks like its raising the transmission too? How should i reinstall it?

THANK YOU, really wanna drive it tomorrow!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:31 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC