Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > clutch and shifting problem

Join Wrangler Forum Today


Thread: clutch and shifting problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-11-2008 08:12 PM
Triple88a Worn out piston cups on the master or slave cylinder. You press the clutch, it builds up pressure but then its lost because of the leak. Step on the clutch 3-4 times and put it in 1st gear (still keep the clutch pressed in and make sure its safe for your jeep to go forward) and wait. If it starts to engage there is a very high chance of it being the piston cups. Check the fluid level afterwards to make sure its not an outside leak.
05-11-2008 07:39 PM
upinar
clutch and shifting problem

I know this is probly not the place to post this but i think more jeepers are on the tj forum and i need the help fast. i have a buddy with a 88 yj with an inline six, manuel transmission. the problem is when the jeep is just started and cold, it shifts perfect and clutch feels strong. But when the jeep is warmed up, the clutch feels soft and becomes very hard to shift, does not grind though, just very hard to get into gear and get out from gear to gear. If i pump the clutch, it get a little easier to shift. clutch still grabs but it sinks to the floor when pressed. Anyone know what the problem is?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC