Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Help! TJ Squeeking Horribly!

Join Wrangler Forum Today


Thread: Help! TJ Squeeking Horribly! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-24-2012 07:39 PM
LULU05
Quote:
Originally Posted by ThatWhiteMachine101
Alright will do. Thanks again all for the replies. The sound is driving me insane! By the way, here's the picture of how I was stuck:
Lol. Wow. Might wanna consider different tires, or use a stick to check the bottom of the hole, but I'm sure I don't have to tell you that. Thats great!
04-24-2012 07:31 PM
coops98TJ WOW!!!! Yep I would check the whole drive train out!!
04-24-2012 06:16 PM
ThatWhiteMachine101 Alright will do. Thanks again all for the replies. The sound is driving me insane! By the way, here's the picture of how I was stuck:
04-24-2012 05:50 PM
coops98TJ
Quote:
Originally Posted by ThatWhiteMachine101 View Post
It wasnt super deep. The mud was up to the body under the door. If its my throw out bearing then why would pullin the driveshaft change anything?
If you were in mud up to the tub for 6 hours I would check everything from the tub down. drain both diffs. and check the clutch and throw out bearing for sure. Pulling the drive shaft could have dislodged some mud in or around the throw out bearing ....... I would check it all out. take no chances..... 6 hours is a long time.
04-24-2012 02:52 PM
ThatWhiteMachine101 It wasnt super deep. The mud was up to the body under the door. If its my throw out bearing then why would pullin the driveshaft change anything?
04-24-2012 04:25 AM
coops98TJ ON a side note ..... If you were stuck in the mud for 6 hours I would also be changing both front and rear diff fluids, checking my axle u-joints and things like that. sitting stuck for that long water and mud can and will find a way in.
04-23-2012 08:31 PM
LULU05
Quote:
Originally Posted by coops98TJ
still how deep was it in the mud? If you have a stick it could be in your throw out bearing also.
Would tend to agree with throwout bearing. Just had to replace entire clutch due to throwout bearing exploding. Starts out with an annoying squeal and will increase the worse it gets. You can replace the throwout bearing pretty inexpensively, but if it gets too bad it can destroy the clutch. Just sayin cuz you mentioned the clutch pedal felt different. Also sometimes the noise would come and go if I slightly placed my foot on the clutch pedal. Hope this helps.
04-23-2012 06:29 PM
coops98TJ still how deep was it in the mud? If you have a stick it could be in your throw out bearing also.
04-23-2012 02:05 PM
ThatWhiteMachine101 Yea I got my cv shaft and U joints checked and they all checked out fine. It must be in the breaks.
04-23-2012 04:17 AM
coops98TJ How deep was your Jeep in the mud? Auto or stick? ...... Lots of things it could be!! Six hours stuck in mud is a long time!
04-23-2012 02:19 AM
carlosprite I also had a squeak after playing in the mud, went away for an hour or so after greasing everything; ended up blowing my rear u-joint. That was the cause for my squeaking.
04-22-2012 10:39 PM
justin_brown Its probly the front CV joint... The only real way to fix it is replace it
04-22-2012 10:33 PM
CMA_Rider Idle squeak, check your serpentine belt and the pulleys
04-22-2012 09:25 PM
ThatWhiteMachine101 Ah okay thanks for the replies! I'll prbly put it on a jack and pull the wheel off and see if that does it. Only thing that bothers me is that it faintly squeaks when I'm idling sometimes. Not sure if it's related or not.
04-22-2012 08:05 PM
CMA_Rider
Quote:
Originally Posted by jrussblues View Post
You've probably got some debris from the puddle stuck in your brakes. I had to pull my wheels off and spray out the front brakes for about 20 mins per side to get all of the junk out after a day of wheeling after it rained. Very similar symptoms as yours.
This^^^ is what happened to me but mine was my rear drums it diddnt squeak when I braked only when I was rollin, I ran threw a clean water hole and it washed em out and the squeak quit.
04-22-2012 07:30 PM
jrussblues You've probably got some debris from the puddle stuck in your brakes. I had to pull my wheels off and spray out the front brakes for about 20 mins per side to get all of the junk out after a day of wheeling after it rained. Very similar symptoms as yours.
04-22-2012 05:44 PM
ThatWhiteMachine101 It doesnt squeak when I brake, it actually gets less loud.
04-22-2012 05:19 PM
CMA_Rider Have you checked your brakes
04-22-2012 05:12 PM
ThatWhiteMachine101
Help! TJ Squeeking Horribly!

so a few weeks ago I took my 2004 TJ sport with a 2 1/2" roughcountry lift on 32s offroad and got highcornered really bad in a mud puddle. I was stuck in that mud puddle for about six hours before i was finally freed As soon as I drove out of the puddle there was this loud sporadic squeek coming out from under my jeep. It isnt like a consistent squeek and it comes and goes. Ive narrowed it down to the drivetrain and I took it to a 4x4 shop and they pulled my driveshaft, cleaned and lubricated my U-Joints. This fixed it for a few days but then it slowly began to come back. I dont know what to do but to take it back and see what they can tell me but I just wanted to see if anyone else has had this problem. Thanks all!
P.S. There is little to no vibration and the clutch feels as though it is a little bit stiffer. Any advice or help would be greatly appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC