Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Electrical/Wiring Issues?

Join Wrangler Forum Today


Thread: Electrical/Wiring Issues? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-13-2012 01:09 AM
mach10 Just finished recharging the battery, and it worked. Thanks ibuildembig!
05-11-2012 04:10 PM
Ibuildembig Yes even if its wired correctly the memory on the radio will draw enough current over time to kill the battery.
05-11-2012 03:17 PM
mach10
Electrical/Wiring Issues?

Im having issues with what I believe has to be with the electrical components of my 1990 YJ, 2.5L. It was sitting all winter, so when I tried to start it, nothing would come on. I noticed that the headlights had been left on, completely killing the 2 year old battery. Luckily, it was still under warranty, so I got a new one. After installing the new battery, the Jeep started like new. I drove it to work for 3 days,and then left siiting again for a week after. Low and behold, when I tried to start it again, nothing. When I turn the key, I dont hear the fuel pump priming, and none of the electrical components come on. The P.O. installed an after market radio, which will be on even when the key is out of the ignition. The only way im able to turn off the radio is by taking the faceplate off. Could this possibly contribute to the jeep not starting?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC