Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum > 1980 CJ-5 won't start

Join Wrangler Forum Today


Thread: 1980 CJ-5 won't start Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-19-2012 06:27 AM
shaneharrelson93 Thanks for all the replies. I will keep posted
05-18-2012 11:42 PM
Cj7otr Careful taking off the timing chain cover. You'll need to re-prime the oil pump. AMC made it a little difficult to check on the timing chain.
05-18-2012 09:41 PM
Rusty jeep Check your distributor gear. The 304 and the 360 are bad about the cam walking toward the front of the motor. When that happens it sheers the gear on the cam and the dist. my 360 did just that. Ran fine then nothing. Just what your describing.
05-18-2012 07:33 PM
4Jeepn could also be a loose vacuum line. I forgot to put one on good and tight on my cj after doing the valve cover replacement. Caused all kind of starting issues.
05-18-2012 07:01 PM
shaneharrelson93 I am taking the timing chain cover off to see if it jumped timing.
05-18-2012 01:19 PM
sevenservices Engine needs three things to run. Fuel, Compression and Spark.

You have fuel,
You have spark,
either you are loosing compression or sparking at the wrong time.
05-18-2012 01:15 PM
shaneharrelson93 I have a 304 v-8
05-18-2012 08:24 AM
1959elcamino try taking off a valve cover.you could have a broken cam
05-16-2012 05:37 AM
shaneharrelson93
1980 CJ-5 won't start

my cj5 stalled one day while i was heading home. It has spark to the coil and plugs. When i pump the gas pedal gas sprays into the carb. It has a brand new ignition control module. I am at a lose. It will turn over but it doesnt fire or sound like its going to start. Any help!!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC