Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In > Speedometer not working

Join Wrangler Forum Today


Thread: Speedometer not working Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-27-2012 10:32 AM
SilverSport Welcome Aboard!
05-27-2012 09:16 AM
blkrubi88 Welcome!
05-27-2012 04:58 AM
MrSig Welcome and enjoy the forum!
05-26-2012 08:30 PM
Beastmaster Sorry, I don't know the answer to your question, you may want to check out this area: http://www.wranglerforum.com/f5/?daysprune=30 and matbe post your question there.

I just wanted to say;

Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
05-26-2012 07:30 PM
Cindyjo
Speedometer not working

My speedometer in my 94 Wrangler is not working and the lights to the speedometer does not work. All the other gages and tach are on and fine. I Disconnected the speed sensor and checked with a meter. Starting from the left - the first pin read 5 v, the second pin on reading and the third pin read 7.5 v. I pulled the cable end out and reinserted and rehooked up the electrical connection. Still no reading or lights on the speedometer. Any suggestions on something else to check?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC