Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > could really use some help on this

Join Wrangler Forum Today


Thread: could really use some help on this Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-15-2012 03:52 AM
KidRock171 Yeah I've seen 2 threads in the past year or 2 that had blown T-case like his.
10-14-2012 10:22 AM
paradox.0215 Wow, that does not look good. Same problem with the CV joint going that caused this?
10-14-2012 03:00 AM
97wrangler-242
Quote:
Originally Posted by KidRock171
Glad you caught it. When that front CV fails it has a nasty habit of splitting the transfer case right in half.
Kinda like this... Lol
06-08-2012 01:26 PM
paradox.0215 Wow, didn't know that. Like I said could be much worse! Lol
06-06-2012 02:29 PM
KidRock171 Glad you caught it. When that front CV fails it has a nasty habit of splitting the transfer case right in half.
06-06-2012 02:03 PM
paradox.0215 Stings a little but could be much worse so I'll take it lol
06-06-2012 12:40 PM
mrpowerz13 For the best I suppose... But still stings a little lol.
06-06-2012 09:13 AM
paradox.0215 Well I was close to the right problem. After changing the U-joints and putting the drive shaft back in I started hearing the sound again. While it was out though I saw the CV joint wasn't looking to hot... I tracked down a rebuild kit for the CV joint now and will be changing that soon too. Anyway hopefully this stuff will all be done soon and I'll be able to get back out on the trails soon. In the mean time just just keeping it on the roads :/
05-30-2012 10:36 AM
mrpowerz13 Good to know!
05-30-2012 09:03 AM
paradox.0215 Just thought I'd give a little update. It's one of the U-joints in the drive shaft between the transfer case and the front differential. I got a little curious last night and pulled the shaft out... sound was gone after that. Either way this weekend I'll be doing all the U-joints from there back that way they're all new and don't have to worry about another U-joints for a while.
05-29-2012 11:30 AM
paradox.0215 I think that'll be my weekend project. U-joints from the front differential back... if that doesn't take care of it I'll come up with something else. Lol Thanks for the input guys, it is very much appreciated.
05-28-2012 11:55 AM
mrpowerz13 Assuming it's coming from the front, I would start with the CV knuckle, then the u joint closest to the transfer case, then the one at the diff. If it's the rear, then replace the the one closest to the transfer case first, then the one at the diff.

Or, you could just do everything at once with upgraded/stronger Spicer joints and not have go worry about it again...
05-28-2012 11:30 AM
paradox.0215
Quote:
Originally Posted by mrpowerz13 View Post
Is it when you're driving straight or turning? If it's when turning only, my guess would be a ball joint or one of the front axle u joints. Do you have lockers up front? If so, maybe your friend accidentially engaged it and tried to turn. (Similar to being in 4low and trying to turn on dry pavement)
My first thought would have been the ball joints then the u-joints at the knuckle but I just replaced all of the about a month ago. It makes the sound whenever I'm moving, not just turning. I'm probably going to replace u-joints this weekend and see how that goes.
Any other ideas are welcome though, I'd like to work on the actual problem so when I'm done it's fixed lol
05-28-2012 10:57 AM
mrpowerz13 Is it when you're driving straight or turning? If it's when turning only, my guess would be a ball joint or one of the front axle u joints. Do you have lockers up front? If so, maybe your friend accidentially engaged it and tried to turn. (Similar to being in 4low and trying to turn on dry pavement)
05-28-2012 10:55 AM
Zjones1994 Check all u joints in front and the front d.s.
Also maybe the throw out bearing.
05-28-2012 10:26 AM
paradox.0215
could really use some help on this

So I've been letting my friend drive my 97 tj for a little while his car was in the shop. I've had it back about two days now and there is a really loud clicking type sound coming from the front center of the jeep. I've been trying to figure out what it is on my own but am about to give up because I see nothing. I just replaced almost the entire front end about a month ago so I know its not from up there. I'm wondering if it might be the u-joint going into the front differential or something my serious like the clutch ( my friend isn't that skilled with manual transmissions).

Everything I read, for the most part was talking about the sound being associated to the rpm's of the engine. In my case however think clicking is tied to the speed, even if I'm rolling down hill with the engine idling I still here the clicking.

If anyone has any idea on what could be making this sound the input would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:58 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC