Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > clicking/tapping upon acceleration 97 2.5 tj...HELP!!

Join Wrangler Forum Today


Thread: clicking/tapping upon acceleration 97 2.5 tj...HELP!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-02-2012 02:59 PM
wwch99tj
Quote:
Originally Posted by Moody715

Turned out mine was a broken piston skirt and if you run it like that you WILL scar up the inside of the piston walls bad
That's the same thing that happened to mine, I ended up replacing the engine last march
06-02-2012 02:28 PM
Moody715
Quote:
Originally Posted by wwch99tj
Could be a broken piston skirt
I would agree here! I had the same problem last october and ended blowing a head gasket and rebuilding my engine. I would really look into fixing it before it becomes a bigger (more expensive) problem.

Turned out mine was a broken piston skirt and if you run it like that you WILL scar up the inside of the piston walls bad
06-02-2012 01:26 PM
wwch99tj Could be a broken piston skirt
06-02-2012 01:08 PM
jblaznik using a stethoscope, i found the clicking noise where the back (far right) injector when into the block....unplugged that switch and the noise went away. Does that mean a rod problem? No significant lifter noise from top of valve cover...still frustrated.
06-02-2012 08:00 AM
jblaznik
Quote:
Originally Posted by rpk73 View Post
Is it only happening at low rpms upon acceleration? Does it sound like a rattle coming from the firewall?
doesn't sound like a rattle....noise is at all rpms.
06-02-2012 07:55 AM
Barrier This sounds like the sound I have been getting although mine seems to be when the Air Conditioner is on. It is intermittent comes on after start-up then seems to go away although might come back. I double checked the oil level, hood rubber gaskets, engine top cover. Seemed to diminish after I topped the oil up (1/3 quart down), but returned.
This is on my 2012 JKU Sahara with auto air. 2500 miles, November 2011 build.
I went back to the dealer but noise was not there when I brought it in. I did not want to leave it for days for it to arrive on a road test. I figure I'll bring it back when I hear it. I will be changing over to synthetic oil in another 500 miles (1st change at 800 miles dino oil), perhaps that will make a difference.
Lew
06-02-2012 07:31 AM
rpk73 Is it only happening at low rpms upon acceleration? Does it sound like a rattle coming from the firewall?
06-02-2012 07:24 AM
jblaznik ....oh yea, also did an engine flush and oil change...no change.
06-02-2012 07:21 AM
jblaznik
clicking/tapping upon acceleration 97 2.5 tj...HELP!!

very annoying, loud tapping/clicking from engine upon immediate start-up, then upon acceleration only. Read some from forum(s); checked the exhaust manifold, found a missing top/left bolt..replaced and tightened other manifold bolts along with visual for cracks...no luck, tapping still there. Tried the 'ole screwdriver at the end of a hose diagnosis trick..can't find the sound. Figured with that method on the valve cover, a sticky lifter would be easy to hear...nope. sound coming from back of motor, mid way down i think. Any ideas or similar discoveries out there? I'm frustrated!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:58 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC