Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 89' 4.2L slow starting....any ideas

Join Wrangler Forum Today


Thread: 89' 4.2L slow starting....any ideas Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-19-2012 11:18 AM
Jrdavidson so, before i try to start the engine, do i just unhook the fuel filter and see if there is gas in it?
06-18-2012 08:56 PM
bryant.manning84
Edit

Quote:
Originally Posted by bryant.manning84 View Post
I just changed the starter on my89 hi and now its great at starting....if the fuel empties out of the filter then yes most definitely the fuel pump......IF IT'S A MECHANICAL PUMP

THAT SHOULD SAY ON MY 89 YJ.....DAMN AUTO CORRECT LOL
06-18-2012 01:20 PM
bryant.manning84 I just changed the starter on my89 hi and now its great at starting....if the fuel empties out of the filter then yes most definitely the fuel pump......IF IT'S A MECHANICAL PUMP
06-18-2012 01:09 PM
Jrdavidson
89' 4.2L slow starting....any ideas

I have 4.2L 258 with a brand new carb (stock). It takes a while sometimes to start. Once it starts, it runs great. Battery is new and that isn't the problem. doesn't seem to be the starter. It really seems to be a fuel issue. Almost like each time i turn off the engine the fuel line empties and then start from scratch each time i start it.


fuel pump issue..i don't know....

Any ideas?


Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC