Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Changed tranny fluid and tcase

Join Wrangler Forum Today


Thread: Changed tranny fluid and tcase Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-19-2012 09:16 PM
joerake I did remove them. Thanks for the help!😄
06-19-2012 09:11 PM
Jerry Bransford Yep, the skidplate lifting the tranny (actually the transfer case) up a tad when reinstalling it is normal since that is what supports the rear of the engine/transmission/transfer case assembly.

Before you dropped the t-case, you removed the four nuts that secure it to the transmission mount right? Just making sure you did since forgetting to do that can break the transmission mount which could cause vibrations.
06-19-2012 09:02 PM
joerake Thanks Jerry.

I just didn't know if dropping the skid and putting it back maybe I didn't line something up right. I noticed when I put it back on that it pushes the tranny up a little. Is that normal?
06-19-2012 08:57 PM
Jerry Bransford Whatever vibes you're getting, you can feel comfortable that they're not caused by having filled your AX-5 with RP 10W-30 and t-case with ATF+4.
06-19-2012 08:49 PM
joerake
Changed tranny fluid and tcase

Now I feel slight constant vibes at speeds above 60.

Dropped the skid plate to change the fluids. Put everything back together correctly. Could I have done something wrong to cause this. 99 tj. 2.5 ax-5 np231

I put royal purple 10-30 in the tranny and ATF +4 in the tcase.

Thanks for your input.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:55 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC