Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 1995 YJ whistle and CEL

Join Wrangler Forum Today


Thread: 1995 YJ whistle and CEL Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-07-2012 12:19 AM
Bluegrass My Jeep didn't come with one. Just a really busted up muffler. Got to replace the whole deal.
07-06-2012 09:08 PM
urban_offroader I finally got around to getting the cat replaced. The matrix was almost completely gone, except for a chunk lodged sideways at the rear of the cat. Also the mounting rod at the front of the cat had broken off, leaving a hole, which was probably causing the whistle before it got too big. The rig is a lot quieter, maybe a bit more power, and I haven't had a CEL. On the downside, the missing matrix material from the old cat is now rattling around in my muffler. So if your cat is going don't wait too long unless you want to listen to it for a long time.
06-21-2012 08:12 AM
jfbilbro i'm with you on the CC......mine had the same problem and new cat cleared it right on up..
06-21-2012 01:04 AM
urban_offroader The hiss came back today and the CEL is back on, with the same 2 codes. Power seemed down, though it's hard to tell when there isn't much to begin with.

Here's my theory:

The catalytic converter has been rattling for a couple months and is getting worse. I think it's obstructing the exhaust, causing power loss, and the hissing noise is exhaust rushing through the collapsing catalyst matrix. (Noise due to a vacuum leak should decrease with open throttle; manifold vacuum is greatest with a closed throttle.) The exhaust backup causes the O2 sensor to read improperly, throwing a code. Further evidence is the fact that the issue is precipitated by WOT operation - in the mountains and this afternoon when I got tired of the right-hand lane.

Any takers?
06-20-2012 01:51 AM
Bluegrass It can result in a poor idle, so I would think so. Not a pro by far but if you go looking for it grab a can of carb cleaner and spray around. When you hit the cracked line the motor will rev up (btw.. Have your Jeep on and out of gear when testing)..
06-20-2012 01:41 AM
urban_offroader Would a vacuum leak cause power loss? Has anyone had a vacuum leak that suddenly went away, resulting in power gain?
06-19-2012 01:54 PM
Redrider94 You probably have a vacuum leak!!
06-18-2012 10:55 PM
urban_offroader
1995 YJ whistle and CEL

Hello all,
I recently took my new-to-me 1995 YJ with 4 cyl, 5 spd, and 115k to the mountains. As I climbed a long grade with the throttle buried, I noticed a new whistling noise. It sounded just like a turbo - it increased in pitch with throttle position, becoming more of a loud hiss at WOT, and changes in pitch lagged throttle input. The sound did not correlate with engine or vehicle speed. At the same time I felt power loss, which I thought at first was altitude, except except that while climbing another grade, with the throttle floored, the hiss suddenly stopped and I instantly felt a significant power gain. This happened twice in the mountains, and has not happened again in two weeks of driving around at sea level.

I checked codes today and got a 12 and 51. I believe 12 is less than 50 power cycles and 51 is Oxygen sensor - lean condition.

What could cause this intermittent whistle and power loss? Has anyone experienced something similar?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC