Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > engine shifted down while working on clutch?

Join Wrangler Forum Today


Thread: engine shifted down while working on clutch? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-06-2012 09:08 PM
mcseang loosen the trans mount, it will allow the motor to go forward once you jack it up
07-05-2012 11:11 AM
bassassassin thanks man
07-05-2012 11:08 AM
stykthyn Absolutely
07-05-2012 11:07 AM
bassassassin what if it breaks the seal of the oil filter when i let it back down? should i try and replace the motor mounts?
07-05-2012 11:04 AM
stykthyn Sounds like you didn't support the engine and you broke a motor mount. Place a block of wood under the oil pan and jack it up until you can get to the oil filter.
07-05-2012 11:04 AM
RednekYJ Take a look at the motor mounts. 1 maybe broken, or both.
07-05-2012 10:58 AM
bassassassin
engine shifted down while working on clutch?

i replaced the pressure plate in my clutch a few days ago and now my engine has shifted down about an inch. when the engine moved it broke the seal on my oil filter and all the oil sprayed out. now i cannot get the filter back on. what could i do to get my engine back to its normal position? kinda need quick answer as this is my daily driver.

thanks, austin

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC