Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > O2 Sensor

Join Wrangler Forum Today


Thread: O2 Sensor Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-09-2012 01:34 PM
jeeps4u2nv88 We just installed a 3.25" suspension lift by rough country. Only have had the Jeep for a couple weeks now. So much fun to drive! Thanks again for the help.
07-09-2012 01:01 PM
Fatherof2 It's a 97 SE with just a 2" budget boost right now.
07-09-2012 12:57 PM
jeeps4u2nv88 Thanks! Thats good to know. What year is your Jeep? looking at your picture it looks like its the same color as mine. Any lift on it as well?
07-09-2012 12:45 PM
Fatherof2 I just replaced the upstream O2 sensor on mine the other day. It is located on the exhaust pipe just after where it connects to the xhaust manifold. I just used a 7/8 wrench to pull it out and put the new one in. Very easy to do, but remember to put a little anti-seize on the threads before you put the new one back in. Haven't had to change the one after the cat yet. I'm sure it is just about as simple.
07-09-2012 12:03 PM
jeeps4u2nv88
O2 Sensor

I have a 1998 TJ. I believe itís an SE. It has a 2.5 5 speed in it. The check engine light is on and while we were getting the rough country lift installed I had it checked. The service center said it was the O2 sensor.
My question is, is there anyone out there that could tell me where it is located and how to go about uninstalling it and reinstalling a new one. This is one project I would like to tackle myself. Any information would be great.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:26 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC