Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Please help me get my jeep running like a real vehicle.

Join Wrangler Forum Today


Thread: Please help me get my jeep running like a real vehicle. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-17-2012 05:53 PM
AZ WRANGLER Start with the easy, cheap stuff first. Double check all your grounds. You mentioned the electrical system had burned up at some point? You might have a ground wire not making a good connection. Are you sure the ignition is wired correctly?


You can check the fuel pressure with a guage, pretty easy to do.

I would definatley check all the vacuum lines. Does the distributor have a vacuum advance on it?
07-17-2012 03:23 PM
89YJ Convert bump
07-16-2012 11:41 PM
89YJ Convert I've changed out at least half the vacuum lines. guess i'll be checking the rest tm. I checked the fuel filter just the other day, completely clean. I'm leaning toward low fuel pressure. either a regulator or pump problem.

and I've got the weber on there. never woulda bought it if it had the carter haha.

more info that i probably shoulda posted in the first place, 89 laredo, 4.2 5spd.
07-16-2012 11:08 PM
busemans you need a different carb. you are still running the stock carb, right? change it for a weber, motorcraft, holley, anything other then the stock carter
07-16-2012 10:16 PM
Shanman It sounds like you need to check all of your vacuum lines. Maybe tune up and fuel filter
07-16-2012 09:42 PM
89YJ Convert
Please help me get my jeep running like a real vehicle.

I've put a new exhaust system on. I've gotten a new header because the old one was warped. I've gotten a new oil pan. I've replaced parts of the electrical system because the ignition system fried itself.... and it still wont run reliably for more than a day. it was running fine two days ago, tried driving it to go to a job interview yesterday and it died on me. it died repeatedly to the gas station where I tried to fix the problem, and then it died repeatedly all the way home.

basically it will die anytime its idling. I've adjusted the carburetor air fuel mix, idle speed, tried adjusting the timing thinking maybe it was something there. it wasnt any of it. it just refuses to run right. sometimes after starting it, it'll run fine at idle, sometimes it'll run rough. either way the second you hit the gas you better not let the rpm go down or it'll die. this is a new problem as of two days ago. it was running fine after I replaced half the damn thing.

I need this car to get a job. I'm pulling my goddamned hair out trying to make it run for more than a day. man, I had it running so nice too. also, it ate my timing light... I think its just a damn evil jeep.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:53 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC