Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Installed my RE 3.5" coils / drive shaft hitting skid

Join Wrangler Forum Today


Thread: Installed my RE 3.5" coils / drive shaft hitting skid Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-29-2008 11:06 PM
cherokee980 Thanks for the info guys. I will remove it in the morning and get something fabbed up in the next couple weeks!!
08-29-2008 09:57 PM
AzTJ Most people just remove that skid until they can get one that covers the oil-pan and tranny in one shot. I think the Rokmen have a new skid that does that.
08-29-2008 09:52 PM
tazmann910 This is very common. There are a few fixes. I cut the cross member and they welded the cross member up and over the drive shaft. We have a couple of guys that have done very similar things. I don't have a picture of it, but I think you get the idea.
08-29-2008 09:48 PM
cherokee980
Installed my RE 3.5" coils / drive shaft hitting skid

Hey guys,
a buddy and myself just finished installing 3.5" RE coils on all (4) corners of the Rubiclone....now the issue...I noticed that there is only about 2" clearance between the front drive shaft and the trans skid / cross brace. when I put a jack under the bumper and lifted it up to get the suspension to droop...the DS was hitting the front of the skid / cross brace. Any fixes for this?? Need help!!! Anyone else ran into this problem?? Pics of your fix?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC