Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum > Electrical gurus?

Join Wrangler Forum Today


Thread: Electrical gurus? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-23-2012 03:14 PM
CJ-John I've changed the flasher and the bulb now still the same. i guess I'll have to look at changing the switch, but the indicator in the speedo flashes. John
07-20-2012 03:14 PM
CJ-John
Quote:
Originally Posted by Ibuildembig View Post
Id check the bulb first and maybe swap it with the left one if it works correctly. Or you can test it with a meter and see if it flashes at the contact points on the light itself, but you will need someone to hold the lever up for you.
Yeah, I'll pull the bulb again but it works on both filaments for parking lights and 4 way flashers so? I'll give it a try. I've cleaned the ground once but I may do it again. Even thought about running a direct battery ground just hanging a wire down the outside for a test.
07-20-2012 10:52 AM
Ibuildembig Id check the bulb first and maybe swap it with the left one if it works correctly. Or you can test it with a meter and see if it flashes at the contact points on the light itself, but you will need someone to hold the lever up for you.
07-20-2012 10:45 AM
CJ-John
Electrical gurus?

I'm having trouble with getting all my rear lights working properly. tail lights both work, brake lights both work, 4 way flashers and brake lights work but my right turn signal won't flash. now the turn signal uses the same circuit as the brake and 4 ways right? Also the indicator light in the speedo flashes for the right turn when I turn it on but the rear light does not. Now I do know that the switch for the right turn does not latch on (I have to hold it up) Any ideas? I do have another column that the switch latches on but I'm not sure it's a direct swap as I took it out of a 84 and mine is a 79 Thanks in advance. John

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC