Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > battery/charging problem

Join Wrangler Forum Today


Thread: battery/charging problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-02-2008 10:06 PM
slf41002 I wouldn't disconnect the battery cables to check the alternator due to the fact it is an 04 and doing so can spike the regulator and fry the computer.I would try another battery in it first from something else if possible because it sounds like it has a cell short in the battery also if you have a volt meter test the batt with the engine running if you can do so and it should read around 14 volts if the alt is charging if it is very far below that your alt is not charging.
09-02-2008 09:37 PM
CVFD76 yea i would bet on the alternator. if it was ur battery once u jump started it it should run fine. to test wich one it is, jump it, if it stays runnin long enough, disconnect your neg battery connection, if the jeep still runs shitty or cuts off id put money on ur alternator. if it were the battery, once it was jumped, the volt meter would hold steady where it normally is, this is because the battery is only used to get the innitial power to the starter to turn the engine over, and of course little things like remote wires and stuff like that, but as far as the engine goes, once its started it runs off the alternator not the battery, also before you go buy a new alternator, check all your connections, and clean any corrosion/dirt/ and watever alse aint supposed to be there, iv had that problem b 4, some people would suggest putting... anyone know what that grease is called for electrical connections? anyways, some people would say put that on there, personally iv never seen where it made a difference.
09-02-2008 09:11 PM
Atthehop What does the volt meter read when it starts. It sounds like you alternator is not charging.
09-02-2008 02:25 PM
Warpman89
battery/charging problem

i left my lights on this morning and had to jump start it. now, when idleing, the rpm goes really low, an sometimes shuts off. i can only assume the battery is the original from 2004. what is the problem here? i need to drive to school everyday, should i replace my battery? along those lines, what is the general opinion of optima red top batteries? thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:46 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC