Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Downhill assist??

Join Wrangler Forum Today


Thread: Downhill assist?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-21-2012 12:30 AM
auburnJEEP
Quote:
Originally Posted by Sueby View Post
You have to push the button to turn it on - it turns a light on on the dash too. You'll know when it working - you can feel the brakes working.
The few times i tried it the light went on showing it was turned on but i did not feel it working. Only that one time when i used it reversing down hill did i feel the brakes grabbing.
07-20-2012 07:10 AM
Sueby You have to push the button to turn it on - it turns a light on on the dash too. You'll know when it working - you can feel the brakes working.
07-20-2012 12:48 AM
auburnJEEP Mine only seemed to work in reverse, I could feel my brakes grabbing on a really steep hill. Maybe I'm crazy, but going down front first didn't seem to do anything? I'm not sure if I am using it right? I will dry again on the steeps sometime. I find I forget about it most of the time.
06-16-2012 11:07 AM
GCDMD
Quote:
Originally Posted by chim-chim7 View Post
Um, you will need it when your trying to creep down a rock face, and anything other than snail speed will allow the back end to pass your front end. When your rear axle is up in the air 3 feet all the way down the face, you know it's steep.
Damn, that is steep.
06-16-2012 03:42 AM
chim-chim7 Um, you will need it when your trying to creep down a rock face, and anything other than snail speed will allow the back end to pass your front end. When your rear axle is up in the air 3 feet all the way down the face, you know it's steep.
06-15-2012 11:32 PM
RubiJK12 With the Rubi crawl ratio, 4:10 geers, and the 5 speed, I find that down hill speed is really controllable. Shifting into 2, 3 etc. works well to control the speed you want without using the brakes. I've tried the DHA and that is even slower. Haven't found a need for it yet since the 4low range seems to work well, and by shifting up and down, allows you to select a safe speed..
Fun stuff!
06-15-2012 10:54 PM
GCDMD It was frustratingly slow, but I didn't turn anything on beyond just putting it in 1st gear. The hill was VERY steep, the fact the RPMS didn't move at all and I doubt I even went 5mph makes me curious as to what happened. I have gone down many hills with the Rubi, every time the RPMS increase but speed increases only a negligible amount. The fact I had NO increase in RPMS or speed is interesting.
06-15-2012 10:51 PM
Up Hill Bill I've used DHA while in 4-low on steep slopes and it goes so frustratingly slowly that I have turned it off on every occasion and controlled the speed of descent myself with gears and brakes.
06-15-2012 10:31 PM
chim-chim7 4 low in first gear is low enough. The hill you describe wasnt as steep as you think. Its when it wants to haul ass is 4 low without the brakes on. Then you are on a steep enough descent to benefit from the DBA.
06-15-2012 10:14 PM
GCDMD
Downhill assist??

Hey all,

Was out wheeling with the Rubi and happened to come across a very steep downgrade. I slammed it in 4lo and pushed the auto tranny into just 1 (2012 5-speed). The rubi maintained 5 mph without any brakes or even increasing in RPMs, it seemed to maintain 800 RPM and 5 mph the entire way down. The downhill assist light wasn't on, was it on and am I just an idiot? It was cool, but I'm not sure what IT was exactly....

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC