Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Wranger 04 auto trans trouble

Join Wrangler Forum Today


Thread: Wranger 04 auto trans trouble Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2005 10:36 PM
4Jeepn You may want to check TSB's for 2004, I found one, for the auto that said it delt with shift issues.. but it was a pay service.. thus something is out there for it.
08-22-2005 10:08 PM
billbeyer Scoob: I plan to take it back to the dealer, however I would like to have something specific to say. Have you or anyone else experienced the same problem, if so what caused it?
08-22-2005 09:27 PM
Scoob Yeh, take it back to the dealer and tell him you dont give a crap about the codes. It's under warranty. Have his mechanic drive it and fix it. If that result in having to take the time to hook it up to the big computer instead of his little code reader, fine. Once again its under warranty.
But really several things can cause that and a code reader will not pick up on half the things a computerized engine it going through.

Scoob
08-22-2005 08:58 PM
billbeyer
Wranger 04 auto trans trouble

I purchased an '04 TJ Wranger with an L6 and a four speed auto trans. The transmission doesn't seem to want to down shift on a slight incline and the engine knocks. I've tried high octane fuel but that doesn't change anything. The dealer tells me that there are no codes indicating a problem but the problem still exsits. Does anyone have a clue as to what is wrong?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC