Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > a\c charged, won't blow cold

Join Wrangler Forum Today


Thread: a\c charged, won't blow cold Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-25-2012 10:27 PM
DirtyRob
Quote:
Originally Posted by ajorosa View Post
Did you vacuum out the system first?
I concur
If you didn't pull a vacuum on the system you have non-condensables in the system and it will not cool.
07-25-2012 09:26 PM
busemans did you add any oil to the system along with the freon?

i just fixed my ac last week. once i got everything back together, i added two one ounce cans of pag oil and then two cans of freon. my compressor clutch kicked in on the second can of freon and the ac reads 40 at the vent while idling. i did clean my system out with 90 percent alcohol and the air compressor before doing anything though to make sure nothing was in the lines.

if you are worried you got something wrong, let off hte pressure and disconnect the lines from the compressor. pout the alcohol into one the lines and then blow the compressor through it. hook everyhting back up and add two cans of the pag oil from walmart. then add the freon until the gauge reads at the tip of the green. your vent temps should be in the 40s then
07-25-2012 08:15 PM
ajorosa Did you vacuum out the system first?
07-25-2012 08:11 PM
Rednecksedan What u need to do is remove ur doors and drive down the road till u reach 60 nd then u shud be nice and cool
07-25-2012 07:43 PM
chopprr AC? What is that? Lol.
07-25-2012 02:17 PM
Redrider94 I know this might be a stupid question but is the compressor turning? Did you change the orfice tube?
07-25-2012 12:18 PM
edbld
a\c charged, won't blow cold

My 95 yj shreaded the a/c compressor clutch. I put on a new compressor and dryer, and charged it with 2 12 oz. cans of 134. Didn't blow cold, so I added a third can, as autozone told me it held 32oz. Still not cold. I bled off a lot of coolant as other sources say it holds 18 to 22 oz. Still not blowing cold.
Anyone have any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:11 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC