Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Temperature gauge help!

Join Wrangler Forum Today


Thread: Temperature gauge help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-14-2012 07:10 PM
jfbilbro is there a thermostat in the jeep?
08-14-2012 06:11 PM
Gama26b
Quote:
Originally Posted by JBodony
ok I will try cleaning it and let you know if it works. Thanks!
Cool. The digital gauges are awesome they have blue also to match your jeep
08-14-2012 05:50 PM
JBodony ok I will try cleaning it and let you know if it works. Thanks!
08-14-2012 05:36 PM
Gama26b
Quote:
Originally Posted by JBodony View Post
- 1992 YJ 6 Cyl
My temp gauge isn't functioning correctly. On a cold start the gauge acts properly and the needle climbs as the engine warms up. But for some odd reason it stops at around 160. If it's a hot day and I'm riding higher rpms it will slide up to 170.(I imagine this being similar to riding at 210 and it getting hotter to 215-220 ish.) Unless I have some sort of supercooled jeep I'm positive this isn't correct! I replaced the Temp Sending unit on the back of the head. No results. Any ideas before i continue to replace things that aren't broken?
Thanks
gauges are known to get dirty, remove the gauges there is yellow plastic matterial with circuits to it, circut board i guess lol

anyways get sand paper very lightly and i mean lightly sand the female connection then the male connector to the circuit bored, also remove the black plastic piece by the temp gauge and clean with rubbing alcohol that should do the trick, worked for me. if not you should consider jcwhitney.com they have nice digital gauges im thinking of getting
08-14-2012 05:29 PM
JBodony
Temperature gauge help!

- 1992 YJ 6 Cyl
My temp gauge isn't functioning correctly. On a cold start the gauge acts properly and the needle climbs as the engine warms up. But for some odd reason it stops at around 160. If it's a hot day and I'm riding higher rpms it will slide up to 170.(I imagine this being similar to riding at 210 and it getting hotter to 215-220 ish.) Unless I have some sort of supercooled jeep I'm positive this isn't correct! I replaced the Temp Sending unit on the back of the head. No results. Any ideas before i continue to replace things that aren't broken?
Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC