Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > YJ wont start, replaced EVRERYTHING! Please help! ):

Join Wrangler Forum Today


Thread: YJ wont start, replaced EVRERYTHING! Please help! ): Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-15-2012 09:29 PM
1SAS Sparky gave you great advice. One more thing, on my 1992 YJ had a fusible link going to the starter. As mentioned above, check the wires. If one of the wires (going to the starter) looks melted, that is probably what happened... however, this problem sounds like a ground issue... bad battery AND bad ground. If you find the fusible link melted, you can buy more at NAPA.

Take care,
08-15-2012 06:13 PM
sparky So you you replaced some good parts without testing them and it still does not work.

1. Have the battery tested.
2. Clean the battery and starter connections. Don't just look at them, tem them off and clean them.
3. Start tracing your wires and make sure you are getting voltage where it needs to be when it needs to be.
08-15-2012 04:19 PM
Belmont4000
YJ wont start, replaced EVRERYTHING! Please help! ):

As the title says, i have replaced every thing.. but here's the story.

I went out one night, came home slept, woke back up. Turned the key, and got nothing, so sound, and no, its not a dead battery. So, i arch the starter and notice i can still start it, alright. Go to Advanced and get a neutral safety switch and a starter relay, still nothing.

Next day i go out, try to arch the starter, it only clicks. (So now my starter is dead!) Rip it out, bring it up to advanced, and luckily, they gave me one since its a relatively new starter, drop it in, still no key start, but i can arch it.

I was going to look into the ignition switch, but when i turn the key, i can feel the relay click, so i know its giving the signal. From here, i checked all the connections from the battery to the starter, from the fuse box to the starter...ect and even the fuse for the starter. NOTHING.

Pleae save me! I dont like seeing my baby in this condition.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC