Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > What did you do to your JK today?

Join Wrangler Forum Today


Thread: What did you do to your JK today? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Today 04:30 PM
lukeiswright
Quote:
Originally Posted by ArmyofMike View Post
That is the plug in for the rear windshield (heater/windshield wiper motor etc) on a hard top. The hose is for window cleaning fluid. From your pic, you are a soft topper! Just tuck them back in for now.
thank you! I was worried I had messed something up somehow
Today 03:59 PM
ArmyofMike
Quote:
Originally Posted by lukeiswright View Post
took out all of the carpet because water got inside and smelled disgusting. btw does anyone know what this is? while taking the carpet out it popped out.
That is the plug in for the rear windshield (heater/windshield wiper motor etc) on a hard top. The hose is for window cleaning fluid. From your pic, you are a soft topper!

Just tuck them back in for now.
Today 03:51 PM
dmako
Quote:
Originally Posted by lukeiswright View Post
took out all of the carpet because water got inside and smelled disgusting. btw does anyone know what this is? while taking the carpet out it popped out.
Hardtop water hose for spraying window?
Today 03:44 PM
lukeiswright took out all of the carpet because water got inside and smelled disgusting. btw does anyone know what this is? while taking the carpet out it popped out.
Today 02:40 PM
KamikazeKLR
Quote:
Originally Posted by Peter T View Post
Install SRC side armor on the weekend. No problems.

Attachment 1506353
These are awsome. I've had em for a while but finally got to test em out this weekend by sliding around on them. Protects the belly not 100% but damn near. Super solid. I hope you like em as much as I do!!

Also, nice flag!
Today 01:49 PM
pepatrick
Quote:
Originally Posted by Peter T View Post
Install SRC side armor on the weekend. No problems.
That would be the ones..can't wait to get em..
Today 12:08 PM
Pmryall I put mud flaps on the front. I know not exciting bit if I can keep slush and salt from getting all over I'll be happy.
Today 11:46 AM
HAFICON ordered a M.O.R.E off-road dual battery tray. Thanks Ryan at ExtremeTerrain for the hook up. Can wait to get this system online.
Today 10:20 AM
Colorado Dude
Quote:
Originally Posted by Kronk View Post
Hey CO Dude, I was thinking of doing Red Cone next weekend. It doesn't look like it was quite at peak yet, do you think there will be any leaves left by the time I get there?
Thanks.
Kronk, I think you'll be good. I would say this week will be peak viewing time. I think 3/4 of the trees where turned, at the turn off of 285 some of the trees where already bare but up by the start of Webster/Red Cone they where perfect! We'll see what today's weather does too them.
Today 09:58 AM
Peter T Install SRC side armor on the weekend. No problems.

Attachment 1506353
Today 09:19 AM
pepatrick Just ordered SRC side armor. Not a huge fan of Smittybilt products but I have always liked these. They are cheap enough where if they don't work out I can always opt for something else. They should be here on 9-24 so pictures to come one installed.
Today 08:54 AM
andremedia
Quote:
Originally Posted by ArmyofMike View Post
Haha, just razz'n ya! A high pitch squeel when you hit the gas? In gear driving or parked? Usually that is metal to metal at a slight. My guess is your drive line is hitting your exhaust pipes a bit, or another part. Even a slight off center for the drive lines and it feels like the earth is shaking....look for subtle scratches on it or the exhaust pipe...
The kit came with a exhaust extension, to push the exhaust pipes closer to the rear of the car. It also had instruction on slightly moving the Evap canister with skid plate. I'll slide under and check for any scratches.
Today 07:44 AM
nickm757
Quote:
Originally Posted by Mammoth919 View Post
Thanks man. How was the install?
Fairly easy if you get a good wiring harness and you're good with splicing wires. I had a buddy help me out cause I suck with electrical but after watching him I felt bad cause it was pretty straightforward and now I feel confident to do my cube lights when I get them.
Today 07:31 AM
Kronk
Quote:
Originally Posted by Colorado Dude View Post
Wheeled Red Cone pass. Wanted to see the colors changing. Didn't expect to run into 20 yrd visibility. Also first time out with the new lift; metalcloak 2.5 arb edition. Worked so good, was so easy to climb over obstacles that slowed/stopped others. I was really impressed by what I could climb so easily.
Hey CO Dude, I was thinking of doing Red Cone next weekend. It doesn't look like it was quite at peak yet, do you think there will be any leaves left by the time I get there?
Thanks.
Today 04:27 AM
JoseRubicon
Quote:
Originally Posted by Baileyrx View Post
Went topless for the first time! <500 miles
Topless? That's nekid!
Today 12:03 AM
ArmyofMike
Quote:
Originally Posted by andremedia View Post
Total Noob mistake, I'll get the hang of it. Now for some advice? If you got any...
Haha, just razz'n ya!

A high pitch squeel when you hit the gas? In gear driving or parked? Usually that is metal to metal at a slight. My guess is your drive line is hitting your exhaust pipes a bit, or another part. Even a slight off center for the drive lines and it feels like the earth is shaking....look for subtle scratches on it or the exhaust pipe...
Yesterday 11:50 PM
andremedia
Quote:
Originally Posted by ArmyofMike View Post
What "car" are you talking about??? I see a good looking Jeep in your pic!
Total Noob mistake, I'll get the hang of it. Now for some advice? If you got any...
Yesterday 11:44 PM
Dragmod Finally finished mounting and wiring my winch. I installed the interrupt kit on the lid of my genesis dual battery kit. Now I have a safety switch on my sPod. Moved my vacuum pump with the Teraflex kit and finished the wiring of my rear KC lights. Tomorrow I'm going to get the synthetic line installed, cut a space out for the clutch controls in the plastic trim panel, and reinstall my dual note horn back by the firewall. It was a big pain in the butt to get my winch to be hidden but it will be worth it when I'm all done! Attachment 1505769 Attachment 1505777 Attachment 1505785 Attachment 1505793 Attachment 1505801 Attachment 1505809
Yesterday 11:32 PM
Spaste19 Put new plasti-dip on the locks. Old stuff was on about a year and was starting to loosen ans show edges. Then started some research for next years family trip. Somewhere in Colorado or Utah, or both.
Yesterday 11:03 PM
zdevil13 Did a five tire rotation... Then did a quick run down Bulldog Canyon and made it back in time to see the Cards take down the 49ers.
Yesterday 10:56 PM
Mammoth919
Quote:
Originally Posted by BareBones13 View Post
Did you remove the hinges before using plastidip? I was thinking about doing that on my Anvil Willys but am concerned about re-aligning the doors if I take them off. But then I'm a little nervous about not taping/covering the paint if I leave them off
Plastidip is lazy you don't have to tape off exactly. It likes a edge so let it Do it's work. All in prep tho. Clean with alcohol and let dry. Then do light coats with 15 min between coats
Yesterday 10:56 PM
Fleche Got tired of not having any light...or light that wants to turn off all the time without the key... in the back of my JKU, so completed step one of my lighting plan.

I put a switch below, and tapped into, the always on 12v outlet by the sub. Then back mounted a 12 LED strip (yes, it has a bit of wave in the drilling...) from Ozmonium a bit above the outlet. I'm going to add another one on the other side and probably one with the OEM rear light. The vent in the door is begging for some enlightenment as well.





In a pitch black garage. My phone didn't do the lights justice.
Yesterday 10:53 PM
Mammoth919 Thanks man. How was the install?
Yesterday 10:51 PM
ArmyofMike
Quote:
Originally Posted by andremedia View Post
I installed the Stage 3 3" Lift by Teraflex for Mopar, with the fox 2.0 res shocks. I did it with a buddy whose a mechanic but has never done a lift kit before and it took about 16 hours total. I'm really happy with the way it looks and the way the suspension feels, my only concern is that i feel a high frequency vibration when I press on the gas pedal. I'm thinking this is because the angle change caused by the lift. I also put the car into reverse and it started vibrating, the car was shaking. I turned it off and on and it stopped. Any ideas?
What "car" are you talking about??? I see a good looking Jeep in your pic!

Yesterday 10:49 PM
Colorado Dude Wheeled Red Cone pass. Wanted to see the colors changing. Didn't expect to run into 20 yrd visibility. Also first time out with the new lift; metalcloak 2.5 arb edition. Worked so good, was so easy to climb over obstacles that slowed/stopped others. I was really impressed by what I could climb so easily.
Yesterday 10:33 PM
andremedia I installed the Stage 3 3" Lift by Teraflex for Mopar, with the fox 2.0 res shocks. I did it with a buddy whose a mechanic but has never done a lift kit before and it took about 16 hours total. I'm really happy with the way it looks and the way the suspension feels, my only concern is that i feel a high frequency vibration when I press on the gas pedal. I'm thinking this is because the angle change caused by the lift. I also put the car into reverse and it started vibrating, the car was shaking. I turned it off and on and it stopped. Any ideas?
Yesterday 10:11 PM
victor1955
Quote:
Originally Posted by socalrubicon View Post
quit mucking about with side-steps and get a set of real rock sliders! Ace engineering rock sliders: rock sliders
^^^^^this^^^^^
Yesterday 10:00 PM
JerryJeepster
Quote:
Originally Posted by Higgs82 View Post
Broke my side steps yesterday during a trail ride. so today i am removing whats left

Side Steps
Ace engineering rails! You'll have a hard time breaking them!
Yesterday 10:00 PM
JerryJeepster
Quote:
Originally Posted by mikeJKUR View Post
Installed my Superwinch tiger shark 9500 with synthetic rope.



And relocated the solenoid and plug to under the hood.
Been thinking about doing this! Especially since mine has a remote.
Yesterday 09:53 PM
Das_K Replaced chrome tail light covers and chrome gas cap cover with black ones on wife's new ride. Took the tops off and cruised around for a while.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:45 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC