Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > YJ engine sputtering

Join Wrangler Forum Today


Thread: YJ engine sputtering Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-21-2012 03:10 PM
dstryker "OIIIOforlife" thanks for the info. I will look for a computer. If I find one how do I get it programmed to the motor? Dealer?
I have used Lucas injector cleaner and lubricant but I will try Sea Foam also, can't hurt I'm sure.
08-21-2012 12:24 PM
0III0forlife I would take the fuel line off at the beginning of the fuel rail, and get a pressure reading there. If you have adequate fuel pressure there, then check or replace the pressure regulator. The throttle positioning sensor can cause the erratic rpm's as well.

Or possibly the IAC, which is the other sensor in the throttle body. Idle Air control. It acts kinda like a choke on a carb. If it's sticking half closed, it will cause problems and the rough idle when the motor gets warm.

Did you ever try to seafoam the motor? Plenty of videos on youtube to show you how. Works amazing for cleaning out the carbon and sludge deposits in an older motor. Pouring it a drop or 2 at a time into the brake booster vacuum line also helps with cleaning all the carbon build up in the throttle body. Might be an idea.
08-21-2012 12:14 PM
0III0forlife
Quote:
Originally Posted by dstryker View Post
I have also been led to believe it could be the computer. Anyone know where I can find a good used computer? I was also told the computer might have to be programmed to my vehicle. Is that correct? 1990 YJ Wrangler
Your only luck for finding a used computer is if you can find a YJ in a salvage yard with a blown motor. Most yards wont sell just the computer, cause it has to go with the motor.

Yes the computer has to be matched to the motor.
08-21-2012 11:59 AM
dstryker I have also been led to believe it could be the computer. Anyone know where I can find a good used computer? I was also told the computer might have to be programmed to my vehicle. Is that correct? 1990 YJ Wrangler
08-21-2012 11:47 AM
dstryker Don't tell anyone but some one removed the cat before I got it.
08-21-2012 08:23 AM
GrimmJeeper I have an 87 2.5 with the same problem, I have replaced almost everthing exept the Comp, It comes and goes very intermiten. Mine has about 15 psi at the valve at the throtlebody witch is normal and I have replaced and reibuilt the throtlebody, fuel pump, coil, dist, all vac lines replaced, and much much more. Have you tried coolant temp sensor, How does it idle? Is all your ignition perfect? Timing? Good luck, One of the best things we can do is keep updating these threads to keep all of us informed on these problems. I can't tell you how many times I read posts and say thats my exact problem and the post never gets finished I.E Well the problem was ..... GOOD Luck
08-20-2012 09:33 PM
cakes567 Run a tank or 2 of sea foam cleaner threw it just to make sure everything is cleaned out good. It could be a bad cat. If it turns out to be one... change it and start running a higher octane fuel. The cheaper fuel these days destroys cats and.stuff like that
08-20-2012 07:46 PM
pupa1 cat bad
08-20-2012 11:25 AM
dstryker
YJ engine sputtering

I have a 1990 yj 4 cyl and the engine sputters after it warms up. I have replaced the fuel injector, map sensor, the oxygen sensor and fuel filter. It helped a little but still runs rough after it warms up. It has new coil, plugs and wires and comppression on all four cyllinders is steady at 150lbs. It acts like it's not getting enough fuel at higher RPM's. It has been suggested that the fuel pressure regulator might be partially clogged. Any other suggestions?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC