Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > MIL lamp ON and won't go away!

Join Wrangler Forum Today


Thread: MIL lamp ON and won't go away! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2012 07:37 PM
30-284 You got a special lamp just for your mother in law?

Donn
08-22-2012 03:43 PM
Omar
MIL lamp ON and won't go away!

Hi guys, newbie here.

Heads up, on my 2006 TJ Sport the MIL lamp came on.
Read the codes and it was P0296, P0298 or close enough. O2 sensors

Bought New "BOSCH" and replaced all 4, after a few miles light came on again.
Read forums, posts and did troubleshooting procedures short of replacing the ECM and the catalytic converters for 8 months and light won't go away. Not only that, new random codes started to show up: P1713, P1776 and P0152.

Note that there was a TSB issued for some of these problems for years 2005 and under I think, but apparently the 2006 ECM had all these mods installed from the factory as the dealer checked my VIN against the TSB's and my car did not need any of those.

The car ran fine or so I though until I went up to Pike's Peak elevation 14,000+ feet were the TJ started coughing and decided to die. After a few attempts the car started again but it ran very rough until we came back down from altitude.

Several months after fuel injector cleaners and so on I found a thread that mentioned that TJ's like the OEM sensors, thought it was crazy but I was out of options at that point (short of a sticker over the MIL lamp).

The Factory brand for the 2006 TJ is NGK as the dealer told me, more specifically is NTK.

NTK is the division of NGK that deals with O2 sensors, NGK deals with spark plugs. Replaced all four sensors (under $200 for all), reset the ECM and never had a problem since. I have driven the TJ for about a 1000 miles and it's good to go.

Here is the link for the literature on the sensors:
http://www.ngksparkplugs.com/part_fi...uv/results.asp

Came pretty close of getting rid of the car because the light was pretty frustrating, but it was something as simple as using the right brand which I though was crazy but apparently 2006 TJ and Bosch O2 sensors don't like each other.

Hope it helps!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:01 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC