Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > electrical problem...help!!!

Join Wrangler Forum Today


Thread: electrical problem...help!!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-10-2008 10:18 PM
Triple88a 2x ^^ Dont forget to spread some electric grease on the connector when plugging it back in.
10-10-2008 09:41 PM
evas98tj thnx man.....i'll pull it out and check it....
10-08-2008 02:09 AM
Rawkon sounds like a loose connector behind the bezel
10-08-2008 01:26 AM
evas98tj
electrical problem...help!!!

hey guys,

lately i have an electrical problem and i don't know what causing it.... my gauges in my instrument cluster some times shuts down while i'm driving but it doesn't affect running..... the jeep still runs fine while the gauges are shut down while i'm driving and then, it comes back on again after a few minutes.... i thought it was the battery because it won't start one day....after replacing it i thought it fix the problem but i guess not.... so...if any of you guys can tell me what seems to be the problem...it will be great.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC