Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > knocking sound with suspension.

Join Wrangler Forum Today


Thread: knocking sound with suspension. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-07-2012 10:58 AM
JustLearning Yeah I was able to find the problem without a friend. I rocked it around a bit and the noise came straight fro the sway bar links. I don't know why they are making so much noise. I just replaced one of them. I figured this is a good opportunity to get some disconnects anyways.
08-29-2012 08:11 PM
WRNGLR any luck mate ??
08-28-2012 12:32 AM
JustLearning Ok, I will take a look. Thank you
08-26-2012 06:43 AM
WRNGLR check your control arm bushes, they may be worn allowing steering linkages etc to hit.

Put jeep in 4wd low and first gear and get someone to rock jeep back and forth while you lay underneath, you will see if they are moving around too much
08-25-2012 10:08 PM
JustLearning Bump
08-25-2012 09:24 PM
JustLearning
knocking sound with suspension.

I keep hearing this knocking noise anytime my front suspension flexes. I heard the same noise when one of my sway bar links broke, but I replaced it. Even a speed bump causes the sound now. Some help would be great.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:27 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC