Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > A Quick Body Mount Question

Join Wrangler Forum Today


Thread: A Quick Body Mount Question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-20-2008 08:28 AM
dbbd1 Thanks!
10-19-2008 10:17 PM
whiteyj When I replaced mine (on a YJ) the OEM set had both. They basically sandwhich the tab on the frame. On the YJ there was a "mushroom" shaped sleeve that ran through everything on the 6 main points. These six pieces were like $70 total at the dealership.
10-19-2008 10:00 PM
dbbd1
A Quick Body Mount Question

After today, my TJ is squeaking like a buckboard horse-drawn carriage! It seems that my body mounts are shot. I loosened up (quite a bit) the 3 on the driver's side (where it is the worst) and it stopped. It appears to me that I am getting metal-to-metal contact, the metal insert in the mount is exposed (normal?). I would like to get poly's (no need for a body lift yet though). My question is- are the lower, on the under side of the frame, rubber mounts, considered the "body mounts" also? Or are they some other name as part of the body mount "system" and only the rubber between the frame and body are the "mounts?" If I get a kit, I would like these to be included too. This is where the problem seems to be.
As always, you are all great and "thank you."

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC