Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > 2 months guessing, Help

Join Wrangler Forum Today


Thread: 2 months guessing, Help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-02-2012 12:51 AM
cakes567 Do u have water in your fuel? Iv had water in my fuel and have a rodeo Haha. I try not to run cheep fuels anymore
09-01-2012 05:18 PM
1SAS ValleyG,

Do you own the Jeep Factory manual? If not, try ALLDATADIY.com. For $30, you have access to the exact same Jeep OEM manual the technicians use. They go into extreme, even nauseating detail about checking the PCM. It is worth the money to find out.

Take care,
09-01-2012 12:36 PM
2xs
Quote:
Originally Posted by 87yjman View Post
camshaft sensor under distributor cap. loosing sync with crankshaft sensor and wont leave codes. kills asd relay shutting jeep off.
^ perfect.
09-01-2012 12:05 PM
87yjman camshaft sensor under distributor cap. loosing sync with crankshaft sensor and wont leave codes. kills asd relay shutting jeep off.
09-01-2012 11:52 AM
2xs
Quote:
and there is no engine light during or after the vehicle stalls.
Key on with the engine off, the MIL should be on, even if the engine dies the MIL should come on. If it doesnt there is no power to the computer....
Sometimes, after a stall, the MIL might come on after a small wait time, but any more then 10ish seconds and there is a problem.
I would start by checking all the engine and computer grounds...

If this is the case, and there is no mistaking the no mil for no codes....
09-01-2012 11:26 AM
ValleyG
2 months guessing, Help

I've got a 1995 jeep wrangler YJ, 4.0L straight 6.

The first week of july i was driving through town on an extra hot day, 30+ degrees. At a stop light the jeep started bucking violently as i began to drive, i pulled over and the jeep stalled. Since then the jeep starts fine when the engine is cool, it will run until it reaches normal temperature then the bucking begins, the rodeo lasts a few minutes and the engine stalls, the jeep will not start again until the engine has cooled. During the bucking the RPM's drop and pick up again, its a continuing fluctuation. It only behaves like this once the engine gets to temperature, but according to the gauge the engine isnt overheating. We had it at a garage where they replaced the computer and the Crank position sensor, they had it hooked up and said the jeep is showing no codes, and there is no engine light during or after the vehicle stalls.

We have replaced:

spark plugs, filters (air, oil, fuel), fuel pump, throttle position sensor, crank position sensor, the computer, manifold absolute pressure sensor, thermostat, idle air control valve, and the ignition coil. (in that order)


Nothing so far has worked, please help!! We are out of ideas and out of money!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC