Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > HELP! my jeep is runnin RICH!

Join Wrangler Forum Today


Thread: HELP! my jeep is runnin RICH! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-01-2012 11:34 PM
xc130jetmech Thanks guys, I apologize for the absence of details, yes I have done a full tune up, plugs, wires, cap & rotor, fuel Filter, air filter, oil change with filter as well... I have not checked timing, I'm assuming I need a timing light for that, maybe that is my next purchase... I'll keep ya posted!!
09-01-2012 11:08 PM
Nemesis530 You need to post more information for us to being able to give you a decent answer. If not you will get normal answers like check the plugs and such. It's always good to change fuel filter and other cheap normal maintenance items.
09-01-2012 10:57 PM
banks316
Quote:
Originally Posted by xc130jetmech View Post
wow... NOONE has anything to say? this must be a first!!
Get use to it, I put up quite afew question before that never got a response. As for your question. Have you done a full tune up? That includes plugs, wires, cap/rotor, fuel filter, air filter, O2 sensor. Check timing? Injector leaking by?
09-01-2012 09:30 PM
harleydragon I would bet on the float either being set too high or the float needle not cutting the fuel flow off..could even be a piece of trash on the float needle
09-01-2012 08:16 PM
DILLIGAF
Quote:
Originally Posted by xc130jetmech View Post
wow... NOONE has anything to say? this must be a first!!
Have you checked the plugs and air filter, possable the float is allowing fuel to leak past, was shis a slow transition or did it just kinda start...
09-01-2012 01:00 PM
xc130jetmech wow... NOONE has anything to say? this must be a first!!
08-25-2012 08:36 PM
xc130jetmech
HELP! my jeep is runnin RICH!

Hey new to the Jeep world, I have a 89 4 cyl 2.5L but I need help. She runs RICH I know this because it smells of gas when its cranked up, back fires when I shift into neutral at high speed, and it dies when I decelerate from a high speed... I need some help, any ideas are GREATLY apprectiated. Thanks in advance!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC