Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > New to forum. Need some advice.

Join Wrangler Forum Today


Thread: New to forum. Need some advice. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-27-2008 03:00 PM
Jerry Bransford So far as I can tell, you do have to remove the entire dash to replace the heater core on a TJ. I have to do the same thing for my son's Grand Cherokee before it starts getting cold.
10-27-2008 02:32 PM
polebridge
Quote:
Originally Posted by slf41002 View Post
No problems with the heater housing but the shock bolts are a pain.Have you removed the plastic splash guards/inner fenders yet?If not that will allow you to reach the bolts from the top a little better.The nuts are welded to the frame on top but I had to drill two of mine out and put a new bolts in.It works better to drop the new ones in from the top,hence the reason for guard removal.If they are rusty you will more than likely have to drill them out also.It is a pain also because you can barely get a wrench in there let a lone a drill but it can be done.P.S welcome to the WF!!!
Thanks to all for the quick replies.

I have not removed splash guards yet. I will look into that this weekend and hope that helps. Also thanks for the heads up on snapped bolts. I'll spray them down this week.

I am curious. You said no problem with the heater housing. Is this an easy fix? I was thinking that I will need to remove the dash board and that this was going to be a big, time consuming job. Is there an easy way to re-anchor the unit without going through all that trouble?

Thanks for any advice.
10-27-2008 12:15 PM
Jerry Bransford First, repeatedly over time spray the upper bolt heads with a GOOD penetrant like PB-Blaster, Break-Free, or (in last place) Liquid Wrench. Let it work for a while, it takes some time to get into the threads. No, WD-40 will not work for this.

Then you just need a long length of multiple ratchet wrench extensions to be able to reach up to those bolts. I forget how many I need to get up there but I probably have 2' of extensions between the socket and the ratchet wrench to reach the bolts.

But they can snap off if they're corroded (especially if they salt the streets where you live) so make sure to let the PB-Blaster, Break-Free, or Liquid Wrench work on them first. Several days of letting it soak in with repeated sprays is actually highly recommended before you try to get them out. Otherwise, you could be faced with a snapped bolt which then turns the job into a nightmare.
10-27-2008 11:30 AM
slf41002 No problems with the heater housing but the shock bolts are a pain.Have you removed the plastic splash guards/inner fenders yet?If not that will allow you to reach the bolts from the top a little better.The nuts are welded to the frame on top but I had to drill two of mine out and put a new bolts in.It works better to drop the new ones in from the top,hence the reason for guard removal.If they are rusty you will more than likely have to drill them out also.It is a pain also because you can barely get a wrench in there let a lone a drill but it can be done.P.S welcome to the WF!!!
10-27-2008 09:06 AM
polebridge
New to forum. Need some advice.

I am trying to replace the shocks on my '97 TJ. With considerable trouble I got the front ones installed. My question is how in the heck do you get the upper mounting bolts off for the rear shocks. In my case I have two 1/2" bolts holding each shock in place. Problem is I can't seem to get a socket on them and there is not enough room to work with a standard wrench. I am considering removing the gas tank but I hope there is another option here. I have spent quite a lot of time on this one with no luck. It doesn't help that there is rust everywhere under the Jeep.

Anybody have any good tips on how to get these darn things off?

Thanks.

(for anyone interested, I have 160K miles on my Jeep with original clutch and exhaust system. Except for the exhaust header which cracked at just over 100K. I replace that one myself. Other than that the only other problem I haver had is that the heater fan seems to have come loose from the firewall so the defrost does not work very well. I guess I would need to remove the dash to fix this one. Anyone else had this problem?)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:02 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC