Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Michigan Jeep Forum > Tranny troubles

Join Wrangler Forum Today


Thread: Tranny troubles Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-12-2012 09:10 PM
stans1stjeep The pads on either the pressure plate or clutch plate or both, my have gone away.
09-12-2012 07:59 PM
03huskie Thanks I have checked fluid level it's fine and don't see any leaks. Any suggestions on what part of clutch to check and how
09-11-2012 11:18 PM
stans1stjeep Clutch.
09-11-2012 07:38 PM
03huskie
Tranny troubles

My 03 stopped shifting today. With the jeep running and not engaging clutch there is no grinding. With jeep off and in gear I can still roll the jeep. Clutch or tranny what should I check next?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:13 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC