Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 94 yj bogging down/sputtering/high fuel press.??

Join Wrangler Forum Today


Thread: 94 yj bogging down/sputtering/high fuel press.?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-17-2013 06:59 AM
voyager_1700 Hey.. I just ran into a similar issue.. My 93 6cyl idle would surge.. then settle back down.
I got a code 51 (O2 sensor reporting lean condition). She was running rough on the way home.. I was poking around and noticed the back 3 fuel injectors were loose.. Then the magic Check Engine light came on and now I was getting Code 27 (Fuel Injector Control) as well as poor fuel economy about 10mpg
It turned out The fuel return line was crimped restricting flow back to the tank causing high fuel pressure (My mech told me 90 pounds) Causing a rich condition fouling out my plugs and o2 sensor was toast. Just got it back last night no surge and running great..
05-17-2013 01:10 AM
matrix311
Quote:
Originally Posted by cautiocones View Post
Well I feel stupid, wound up being a loose distributer shaft, had about an 1/8th of an inch of play when shaking it around -_-
I have identical symptoms with my 2.5 right now. I really hope this is my problem and plan on checking it out tomorrow. I will post results.
09-23-2012 04:55 PM
Pullsout it's always the littlest things that get you
09-17-2012 06:46 PM
cautiocones Well I feel stupid, wound up being a loose distributer shaft, had about an 1/8th of an inch of play when shaking it around -_-
09-13-2012 10:59 AM
jfbilbro It could also be the crank position sensor, but a clogged cat will do that too....
09-13-2012 09:33 AM
Tyewilly Check the vacuum line to the map sensor, the factory plastic vacuum lines have a tendency to get holes rubbed in them from years of vibration.
09-13-2012 06:48 AM
Pullsout After all the other stuff you've replaced I would think that the exhaust is going to be your only other option. If exhaust can't get out you're gonna have a bad time.
09-13-2012 03:32 AM
cautiocones
94 yj bogging down/sputtering/high fuel press.??

So when my 4 banger gets warm and I'm driving around town I'm having an issue with my idle, it will idle about 800 them drop to about 3-400 then back to 800 and keep fluctuating like its going to stall but it won't. It will also act like its going to bog down when I'm driving and hit the gas it feels like it hits an RPM rev limiter, and I get a loud popping/backfire kinda sound from the engine compartment, any ideas?? Iv replaced everything and I'm running out of ideas! I haven't done a compression check though, could it be a clogged exhaust system? I also have a fuel pressure of 55 psi at the rail with the vacuum tube on or off

This is what Iv replaced - TPS,IAC,Fuel filter, fuel regulator,cleaned injectors, oil change "came out normal" , air filter and cleaned my throttle body and new vacuum hose on fuel regulator and case vent.

I know my muffler is bad due to the chunks rattling around and I think my cat might be bad too?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC