Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > help - i hear a "pop" in front end when turning wheels

Join Wrangler Forum Today


Thread: help - i hear a "pop" in front end when turning wheels Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-09-2008 01:10 AM
Triple88a
Quote:
Originally Posted by flattietj View Post
.....or you can double triangulate your [suspension] and [have] no track bars like me
This is what i want to do too but what did you do with the draglink.. do you still have it or are you all hydraulic?

You got pics too?

Jtalar, he has problems removing it from the axle, not the frame so no need for a pickle fork.
11-08-2008 11:46 PM
jtalar If its at the axle attach point then yeah the bushing is shot as stated above, X2 on the adjustable draglink, soak the hell outta that bolt with some penetrating oil, if it still wont come out you may need to get a pickle fork and a BIG hammer, try not to tear up the grease damn unless you have spares on hand.
11-08-2008 10:36 PM
flattietj cant believe you havent gotten death wobble with that yet....time to upgrade to an adjustable track bar......or you can double triangulate your supspension and ahve no track bars like me
11-08-2008 09:34 PM
vettefever5 edit: where the track bar bolts to the axle...
11-08-2008 06:42 PM
Triple88a there should be a bushing in there.. i guess it's trashed..
11-08-2008 05:06 PM
vettefever5
follow-up

just to follow up on the issue. i had a chance to look at it today in the daylight and was able to see what was causing the pop... it's some play in the bolt where the track bar bolts to the frame.

using the image jerry provided at one point....



when the wheel is turned i can see the bolt jerk from one side to the other and it's causing the pop sound. it's only moving less than 1/4". it was hard to describe it in my original post...

now that i've identified what the issue is, i have to figure out how to tighten it. the bolt is pretty rusted and won't turn so i hit it with pb blaster a few times but it still wouldn't budge. i'm going to keep hitting it with pb until it loosens up, but at least i don't have to worry about it coming apart on me in the meantime.
11-07-2008 02:48 PM
vettefever5 jtalar - good memory. i was going to replace the drag link end because i thought it was contributing to the play in my steering, but after cleaning it up a little bit it didn't look like it was ripped or anything, so i just left it.

i noticed the play was in the steering box so i tightened that up a little bit and it got rid of most of the play, but not all. i didn't want to overtighten it so i just left it the way it was since it was better at least. that was ~3 weeks ago and it was fine until yesterday.

good call about the control arms... i'll check those when i get a chance. thanks
11-07-2008 02:37 PM
jtalar If i am not mistaken, didn't you post another thread that you changed a tie rod, or was it the draglink end? check those and also check the track bar mounting points. I had a similar popping noise that I thought was coming from the rear end, turned out to be my drivers front lower control arm was loose, everytime I turned it popped especially left turns, and when I would hit a speed bump at low speeds it would pop also
11-07-2008 01:43 PM
vettefever5 not so much when i hit a bump, it's more like when i hit the apex of a the turn going around a corner. if i take a right OR left hand turn (normal speed, 10-15mph) when i'm in the middle of the turn i'll hear the pop.

i also hear it when at a stop (engine running, in a parking space for example), if i turn the wheel from the right to left, or left to right... when it passes the center (straight) it'll pop.
11-07-2008 01:02 PM
jtalar Does it pop when you hit a bump? or only while turning left?
11-07-2008 11:58 AM
foxinthemudd good point... sorry didn't read that part in the post... maybe not
11-07-2008 10:55 AM
vettefever5
Quote:
Originally Posted by foxinthemudd View Post
Ball joints! I know that sound all too well. both times I've gotten the pop when turning or backing up and turning its been my ball joints. and what a bit** they are to replace...
would ball joints cause the steering wheel to become off-center while driving?
11-07-2008 10:51 AM
foxinthemudd Ball joints! I know that sound all too well. both times I've gotten the pop when turning or backing up and turning its been my ball joints. and what a bit** they are to replace...
11-07-2008 09:38 AM
MOz Visually inspect the suspension componentry while a buddy runs the steering wheel back and forth. Chances are you have something loose.

If your poer steering was on its way out, you would have different problems (.e.g noisey box, hard spots while turning, intermittent or variable tension on the wheel).
11-07-2008 09:38 AM
Unlimited I think you are headed in the right direction. Check the track bar where it attaches to the frame and also check all of the bushings. The fact that your steering changes leads me to believe that you've narrowed the source of your problem. Hard to think of anything else it could be. If it were just the popping noise, I'd say to check your shock bushings and mounts and your control arm bushings. Good Luck!
11-07-2008 09:25 AM
vettefever5 i do have slight tire rub, but only at full left turn. when i was able to reproduce it in my parking lot the steering was popping when the wheels were in the straight position. the wheels go...

left >>> "pop" center >>> right
left <<< "pop" center <<< right

i've had the car for a month with the same tires, but the noise just started last night.
11-07-2008 09:13 AM
jgano23 could be the tires rubbing on the suspension. i put 31's on my tj before i put the 2" bb on it and it did rub on hard turns. some people have that problem and some dont. Is it only on hard turns or any time you turn the wheel? Could be the tread of the tire catching on something. do you have an agressive tread on the tire?
11-07-2008 08:38 AM
vettefever5
help - i hear a "pop" in front end when turning wheels

i just noticed this sound last night on the way home from work, and today i realized that it's most likely a problem. how big? not sure yet. that's what i need help with.

long story short - when taking a 90 degree corner from one street to another, i hear a "pop" or "bang" sound about halfway through the corner from my front end. i thought it was just my imagination, or maybe the tires struggling to grip the road (it's been raining here).

long story - when i got home, i parked the car and while it was still running i leaned out of the car while turning the wheel from left to right. when turning from full left to full right or vice versa, when the wheels get to the straight position i hear the same sound. again, i chalked it up to tire grip.

when i got my car the wheel was off centered, so a few weeks ago i adjusted the drag link to straighten the wheel so i know it tracks straight now. i noticed that after taking a left hand turn and hearing the pop, the wheel is slightly off centered to the left. when i take a right and hear the pop, the wheel is slightly off centered to the right. if it was off center all the time one way or another i would assume i need to readjust the wheel, but since it changes each time i turn i know something is loose up front.

i haven't had a chance to diagnose it... i just got to work, the ground is wet, and i'm in my work clothes. i'm going to try and get out there this afternoon to look at it after the ground dries, so other than what i hear/feel, i don't have any other symptoms.

the only things i can think of that would cause such an issue are...

1) drag link... maybe not tightened all the way down

2) pitman arm somehow pivoting on the steering box shaft (maybe not tightened by previous owner)

3) some problem with the steering box

any other ideas? what are the symptoms when the steering box starts to go?

i'm going to look at it tomorrow at my parents house with a full array of tools at my disposal, but i just want to make sure my steering isn't going to come apart on the way over. any advice is appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC