Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Zone 4.25 combo lift question

Join Wrangler Forum Today


Thread: Zone 4.25 combo lift question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-14-2013 06:49 PM
Noish Honestly for how slight the vibes are it just wasn't worth it to me to get out in the cold for 5 minutes. Ill probably do it when I get back to the Jeep in around a week. I'm expecting it to help since a lot of people just do that with a lift and we have the motor mount lift on top. Wont hurt at least
04-25-2013 11:53 AM
patspoth20
Quote:
Originally Posted by Noish View Post
The back on mine was smooth. I just went slow because of the fear of breaking a bolt. I did the whole 4.25" and have slight vibes between 30-34mph. Probably will add washers to the tc and see if that helps though it isn't bad as it is.
I'm having the same problem 30-40mph. Did the washers fix the vibrations?
11-25-2012 11:52 AM
Verdl I got close to finishing today-shocks and springs are mounted, all that's left is connecting my sway bar links and the rear track bar. I didn't have help today and snapped a hose on the driver side just behind the track bar relocation bracket I mounted to the axle. Anybody know how bad that might be. I was chased out of the garage before I could finish up. New winter hours have them close 2 hours early.
11-25-2012 03:49 AM
Noish The back on mine was smooth. I just went slow because of the fear of breaking a bolt. I did the whole 4.25" and have slight vibes between 30-34mph. Probably will add washers to the tc and see if that helps though it isn't bad as it is.
11-25-2012 02:16 AM
Verdl So not much if a break on installing the back end? I was really hoping on a smoother day!
11-25-2012 01:51 AM
Coasttrash yeah putting the rear shocks back on was interesting to say the least also the rear trac bar bracket was entertaining. If my compressor was working I would have used the impact ha.
11-25-2012 12:05 AM
JDeBlois Yeah man, just hand tools were good on mine. I used air though, because it was available. Haha the only bad part was getting the rear shocks in the mount
11-24-2012 09:04 PM
Coasttrash I dont remember mine being all that hard to do. I just used hand tools to do it.
11-24-2012 03:44 PM
GoldenSahara00 an impact really helps with the shocks.
11-24-2012 03:43 PM
BLK00TJ I had vibes even with the MML and 3" suspension lift. I had to drop my T-case with 3 washers on each bolt adding up to about a 3/8" drop. Barely noticable but it ticks me off. I should have the cash to do it right by spring along with a tummy tuck and other junk.
11-24-2012 03:31 PM
Verdl That's the plan for after the back is done-i don't mind waiting on the BL. Do you have anything for the rear shocks? Can I break them off Luke I did with the front?
11-24-2012 03:12 PM
GoldenSahara00 At least install the mml. You will be sure your driveline angle is fine, and it won't give you anymore lift. I would add the BL however. It looks better.
11-24-2012 03:06 PM
Verdl So I spent way too much time on the front end springs/shocks today and have the back end to finish up tomorroe. Any help for getting the 4 bolts off the rear shocks? They're tucked away at bad angles in tight spots. I keep hearing the back end goes easier. I'm hoping so...any help now is appreciated.
11-23-2012 05:16 AM
ob269
Quote:
Originally Posted by Verdl
Any updates or changes? Time is still an issue with me and I'm thinking about breaking this up and installing just the suspension today. Anyone else know if that will cause issues?
From what I've seen, there shouldn't be any issues other then maybe needing some washers for a tcase drop..
11-23-2012 02:29 AM
Verdl Any updates or changes? Time is still an issue with me and I'm thinking about breaking this up and installing just the suspension today. Anyone else know if that will cause issues?
09-28-2012 07:03 PM
niisan9178 Alright so an update:

Disclaimer: I am not an automotive terminology expert, so please forgive the vague-ness

I looked under the hood and noticed a hose had popped off from the engine (area). So off I went to the parts store and picked up some clamps that require pliers to pinch. Reattached the hose, and the check engine light went off today!

So now I am back to my original dilemma,
Do I need to install the body lift and motor mount or am I ok with just the 3" suspension?
09-21-2012 01:26 PM
niisan9178 Update:
Got the tires balanced and that reduced the frequency of the death wobble. I still get it maybe 5% of the time? Ugh

Still no vibrations other than what I assume is the tires that I mentioned in a previous post..

Check engine light popped on. The code is 1494. So off i go to research this new development..
09-20-2012 05:39 PM
stircrazy13 x'2 looks great..
09-20-2012 05:34 PM
DarthLEGO Looks good... and post more feedback after a few days if you can. I am seriously considering that exact mod.

(Love the quote!)
09-20-2012 05:30 PM
niisan9178 OK here are the pictures, with just the 3in suspension. No body lift or motor mount.

Any other thoughts on the potential driveshaft angle?
09-20-2012 11:25 AM
Verdl I have this combo and can't wait to get it installed. Every time I think I'll get a break for work I'll have taskings come donw. Maybe next week...
Looking forward to pics and hearing more about how it all works out for you.
09-19-2012 04:52 PM
niisan9178 Right now I have no vibrations except when I am decelerating and I go from 10 mph to 5 mph relatively quickly. But that might be the super swamper boggers that I have on there

And I had before pics on my phone but it decided to die some time during the lift installation. I do have after pics, will try and post them later tonight.
09-19-2012 04:46 PM
txstj More often than not TJ's need a t-case drop at 3" if a SYE is not being used, but sometimes you can get away without. Notice any vibrations under accel, decel, or at all? If you're getting driveshaft vibs, adding a t-case drop should be the fix, but if not you should be fine running without.

O - we need pictures, or the lift install never happened!
09-19-2012 01:04 PM
niisan9178
Zone 4.25 combo lift question

So I finally decided on the zone combo lift. Over the weekend I installed the suspension (3 inch), but ran out of time for the body lift and motor mount. So I drove it home and think that those 3 inches look great right now, there is no need to put the rest of the kit on at this point. I was happy with this thought process until a friend of mine informed me that the increased angle of the ds needs to be rectified. So I asked around and have gotten conflicting reports on what I should do. Some people say 3 in is fine, others say put the motor mount and body lift on.

(sorry for the wall of text)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC