Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > fuel pump problem in jeep wrangler to chevy engine conversion

Join Wrangler Forum Today


Thread: fuel pump problem in jeep wrangler to chevy engine conversion Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-11-2008 03:44 PM
Coyote_94YJ No prob. I'm here to help.
11-11-2008 03:41 PM
Lancem
Quote:
Originally Posted by coyote_94yj View Post
He is talking about a Hobbs switch. You'll want a normally open one. You will want to put a tee inline with your oil pressure gauge and hook it up there.
Here is one on ebay.
NEW HOBBS PRESSURE SWITCH 4 PSI NORMALLY OPEN - eBay (item 180305885345 end time Nov-18-08 09:27:33 PST)

Thanks Lancem I forgot to mention that.
That's it! thanks that makes things easier!

Lance
11-11-2008 03:40 PM
Lancem I did a quick look at Mcmaster.com, the cheapest switch they had there that would do the job was like $22, part # 3460K41. An easier and probably cheaper way to do it would be to use relay and a regular oil pressure sensor that a car uses to turn on an idiot light. You would need a single or double pole, double throw relay, and the sensor. Wire the relay power from switched 12V to the sensor, the sensor will be ground at zero oil pressure. So with the key on and engine not running the relay will be engaged OK? Now wire the fuel pump through the relay so that when the key is on, engine is running, the relay will be disengaged because the sensor is no longer grounded and those contacts will be running the pump. Wish I could draw a picture it would be a hell of a lot easier to explain! Anyway with the relay turned on there would be no fuel pump(no oil pressure), relay turned off the fuel pump would be on (you have oil pressure), oh and you would have to Tee in the sensor with your normal oil pressure sending unit.

Probably clear as mud right??
11-11-2008 03:38 PM
Coyote_94YJ He is talking about a Hobbs switch. You'll want a normally open one. You will want to put a tee inline with your oil pressure gauge and hook it up there.
Here is one on ebay.
NEW HOBBS PRESSURE SWITCH 4 PSI NORMALLY OPEN - eBay (item 180305885345 end time Nov-18-08 09:27:33 PST)

Thanks Lancem I forgot to mention that.
11-11-2008 01:23 PM
guardian What kind of switch are you talking about and how would you hook something like that up?
11-11-2008 11:28 AM
Lancem One thing to remember doing that with a jumper, you crash and a fuel line ruptures gas pumps out at around 45 PSI until the key is turned off. I would suggest something like a switch that uses oil pressure to close the switch, that way once you start the engine you get oil pressure, and fuel, engine dies you loose oil pressure and the fuel stops.
11-11-2008 07:22 AM
guardian Thanks for all of the help you gave me. This is a great site. Thanks again.
11-10-2008 07:42 PM
Coyote_94YJ I had the same problem. Your computer still thinks your running a 2.5L with injection so its priming the fuel system. That's where your 3 seconds is coming from. But the computer is no longer getting a signal from the engine that tells it that its running so it never energizes the fuel pump relay. That's where your problem is. It's a very simple fix and there are 2 ways to do it. First would be to run a new wire that's hot while the ignition is on to the fuel pump. Or you can do what I did and remove the fuel pump relay and run a jumper wire using to crimp connectors and a really short piece of wire.

Here is a pic of what mine looks like.

11-10-2008 05:12 PM
guardian
fuel pump problem in jeep wrangler to chevy engine conversion

--------------------------------------------------------------------------------

I am doing a 350 engine swap in a 89 jeep wrangler with a 700r4 tranny and a 231C chevy transfer case,edelbrock carb. and Mr. Gasket regulator with a return line. In earlier posts it was said to just use a regulator to regulate the fuel from the existing pump. The problem i am having is when i turn key on the fuel pump it will energize for 3 seconds and motor will start normally but motor will stop running after it runs the gas out of fuel bowl. I know the fuel pump is not pumping after motor starts because i am using a see thru filter. Any ideas with problem? The original motor was a 2.5 tbi and i am using a edelbrock carb. on chevy 350.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:03 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC