Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Spongy brake pedal and slllooowwww wipers

Join Wrangler Forum Today


Thread: Spongy brake pedal and slllooowwww wipers Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-23-2012 03:24 PM
Bill_FL bleeders are on top, installed correct. I have not pulled the rears off to see what kind of shape they are in. I will do that before jumping in with the MC.
09-23-2012 01:36 PM
tchoberg Check to make sure the bleeders on the front brake cylinders are on TOP because they can be installed backwards, left to right, right to left. If so, the bleeders are then located on the bottom of the cylinder and air will accumulate on top and never bleed out.
09-23-2012 11:15 AM
90DesertTanYJ I have to agree, its the M/C if your rear brake hydraulics are in good shape and you replaced the calipers. Nothing else left.

They do leak internally or bypassing.
09-22-2012 05:22 PM
jcbrindle The wipers are electric not vacuum, its probably either a bad column switch or motor. The motor is located in the windshield frame in front of the driver seat. I'm having brake issue's too, you might have a master cylinder that is bypassing. I just ordered a rebuild kit from rock auto for $8 because I'm having similar symptoms.
09-22-2012 04:20 PM
Bill_FL
Spongy brake pedal and slllooowwww wipers

My new to me YJ has some on going issues. Last week I replaced the ICM and did a basic tune up which has made it run great. The right front has sounded and felt like the brake was dragging, and the pedal has been soft since I bought it.

I pulled the front wheels off this morning and the right front brakes looked brand new. New rotors and pads, but a closer look at the right front found the piston was rusted and frozen in place, causing the drag. Since I was doing it, i just replaced both. That fixed the drag, but not the soft pedal. I bled and rebled the brakes. While better than before, its not right. I can only lock up the left front. I started to wonder about the rear and brake lines, etc, then wondered about the vacuum system. While I have not got to it yet, the wipers when on low do not move at all and when on hi look like its slower than on low. This has made me wonder about a vacuum leak. If these were your symptoms, where would you start looking for the leak? In a couple of weeks I will have time to replace the rear brakes too. Cant wait to do an axle swap so I can go to 4 wheel discs. i hate drum brakes.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC