Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 2.5l bucks in neutral when coming to a stop.

Join Wrangler Forum Today


Thread: 2.5l bucks in neutral when coming to a stop. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-27-2012 05:17 PM
punchesdfw My Daughter's was acting similarly. The 1/2, 2/3 and 3/4 syncros were worn out and 2nd gear had broken cogs. Had to completely rebuild it.
09-27-2012 11:56 AM
atanaciop
2.5l bucks in neutral when coming to a stop.

I've been trying to find other posts with similar symptoms but have been unsuccessful. My 2.5l clunks and bucks a tad when I'm coming to a stop in neutral. Only happens around or under 10mph. Sometimes its hard and multiple clunks, and sometimes its just one soft clunk. If I hold the clutch in while in neutral coming to a stop it won't clunk, but it will be hard to put into first or second gear. Also when shifting from first to second gear I get a clunk when disengaging 1st gear, I can hold the clutch in and coast in first, but as soon as I shift into neutral from first to second, it clunks. Any input would be appreciated thanks. The fluid was changed about 3 months ago.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:35 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC