Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Anyone have problems w/dash electronics?

Join Wrangler Forum Today


Thread: Anyone have problems w/dash electronics? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-26-2006 12:16 AM
99 AZSahara I have the same issue, the only good thing for the owner is that miles are not logged when it is shorted out.
04-15-2005 03:42 PM
JeepCrawler98 I would think that could help - I think it's always a good idea to put electric grease on any connector that's going to be undisturbed for long periods of time.
04-15-2005 02:32 PM
daddyjeep I work in a dealership and I am very offended ...just kidding. Would it also help to put some electrical grease on the connections to help avoid corrosion?
04-14-2005 09:42 PM
JeepCrawler98 Hahah, I know what you mean - you'd figure stealership's would be aware of "common problems" and "common fixes" for their own sake.
04-14-2005 09:55 AM
BlackTjID
Thanks

I appreciate the help. I'll try that. I'll have to raz the dealership if it works, and let them know a non-certified, wanna-be garage mechanic, does better work, than their so called technicians.

Again thanks!
04-14-2005 12:31 AM
JeepCrawler98 VERY common problem. There is a dis-simmilar metals reaction taht takes place between the aluminum and steel in the gauge cluster's connection. This causes corrosion that makes for a crappy connection. Pull the cluster out (it's like 4 or 5 screws), carefully clean the pins off with some sand paper and alcohol/Qtips, then bend the pins on the male connectors just a hair, and stick the cluster back in. It should work - I had this problem, before the cluster got really screw up (not related to this issue) and I replace my dash alltogether.
04-14-2005 12:26 AM
BlackTjID
Anyone have problems w/dash electronics?

I have a 98 Tj - Sahara Model.
I bought it used from a local dealer and on my first test drive, I noticed the tach and speedometer would go dead, although all the other gauges continued to work, also the airbag warning light would come on. Before buying it, I told them I wanted that fixed, they said no problem. This was the beginning of the problem. They told me they fixed, found a bare wire, yeah, that's what we found. Anyway, it contiuned to have problems so I took it back and went the rounds to have it fixed. I had to do some research, and found out that there was a Jeep memo that talked about this problem, and that the fix is a module that needs to be replaced. The dealership paid for a Jeep dealership to fix it. Only that just made the problem worse, now the dash is "off" more than it is "on". The jeep dealer also said the module had already been replaced, and said they tried something else, but said they couldn't guarantee their work.

Has anyone else out there had a similar problem with their dash? How did you fix it, if a dealership can't even figure it out. I have no confidence in our local "jeep" dealer.

I have a friend with an 98 XJ and his jeep just started doing the same thing. I've owned a few jeeps, but dealing with this problem, and dishonest dealerships has taken most of the fun out of the Tj.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC