Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > High oil pressure?

Join Wrangler Forum Today


Thread: High oil pressure? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-26-2013 06:57 AM
RMD3 I bought my 99 3 months ago and the pressure has consistently been between 40-50...never higher, never lower. I changed the oil yesterday and it's now at 60.

Any idea what could be causing this? Thanks!
11-26-2013 06:33 AM
Rmadrinan I have a 2000 jeep wrangler and i went mudding last weekend, we wash the motor and the jeep but the following day i started and the oil pressure went too high and blow the oil filter ring. I installed a new filter add oil and when started did the same, the oil pressure is too high and damage the oil filter again. I change the filter but i started with low oil and the pressure is on 80.
Any ideas
10-09-2012 08:06 PM
Patrick H I tried Lucas in one of my Dauntless V6's (that's a factory installed Buick V6 1966-1971 Jeep CJ's for you Jeep newbies) that had a ticking lifter. Twice after a long highway run (4.88's and 33's, before I installed the overdrive) when I slowed down to idle all the lifters clattered like mad, as in they wouldn't stay pumped up. I changed the oil, going back to straight Castrol 10W30, and it never happened again.
10-09-2012 07:33 PM
Jerry Bransford Probably the wrong oil pressure sender then if your oil pressure never drops below midscale. I would DEFINITELY DEFINITELY DEFINITELY not run Lucas "oil stabilizer" in any engine oil, gear lube, transmission, nothin'. Additives generally do nothing but degrade the performance of modern multiweight engine oils and gear lubes... especially Lucas Oil Stabilizer which has been shown to encourage the oil to trap air and turn into a frothy mess.

Each and every major oil manufacturer recommends additives not be added, their careful blends of additives and chemicals would only be screwed up with some catch-all additive the oil doesn't need or is helped by in the least. Really.
10-09-2012 07:00 PM
NCCoumbe
Quote:
Originally Posted by Jerry Bransford
Unusual your '97 does that which if the pressure gauge doesn't drop down at idle RPMs makes me believe someone may have installed an oil pressure sensor meant for a newer model TJ. My '97 TJ's oil pressure gauge varied up and down in step with engine RPMs as it should have.

Also, what viscosity oil is in your engine? Too high of a viscosity can create an abnormally high oil pressure indication.
I have 5w-30 with Lucas oil stabilizer.
10-09-2012 06:58 PM
NCCoumbe I have a 2000 4.0 that's almost completely stock. It "should" be the OEM oil system.
10-09-2012 06:57 PM
Beachcomber My 01 also goes up and down based on RPM's but never below 20.
10-09-2012 06:30 PM
kfdjason7620
Quote:
Originally Posted by Jerry Bransford
Unusual your '97 does that which if the pressure gauge doesn't drop down at idle RPMs makes me believe someone may have installed an oil pressure sensor meant for a newer model TJ. My '97 TJ's oil pressure gauge varied up and down in step with engine RPMs as it should have.
Same as my '00
10-09-2012 06:26 PM
Jerry Bransford Unusual your '97 does that which if the pressure gauge doesn't drop down at idle RPMs makes me believe someone may have installed an oil pressure sensor meant for a newer model TJ. My '97 TJ's oil pressure gauge varied up and down in step with engine RPMs as it should have.

Also, what viscosity oil is in your engine? Too high of a viscosity can create an abnormally high oil pressure indication.
10-09-2012 06:26 PM
SeVeReDiStOrTiOn Yea that's normal, does it drop a little at idle when fully warm? If you think you have some sludging/blockage synthetic oil will clean it out...autoRX additive works really good too. But it looks ok..
10-09-2012 06:23 PM
meili34 I've got a '97 and mine does the same thing. In fact, mine goes higher than that while I'm driving ... never had any problems with that though.
10-09-2012 06:23 PM
kfdjason7620 Looks like you are not up to temperature yet, mine stays about the same as yours while idling until the oil gets good and hot for a while, but then it starts showing about 60 at speed and 20 when idling
10-09-2012 06:22 PM
Jerry Bransford Newer TJ oil pressure gauges have been programmed to never show the normal ups and downs of oil pressure which was scaring some owners. So long as the oil pressure is ok in a newer TJ, the computer will always show a mid-scale reading.

Assuming of course your TJ is newer... I think they reprogrammed it 2001-2002 or so. Older TJs do show a fairly accurate oil pressure so long as the right oil pressure sender has been installed.
10-09-2012 06:10 PM
JVLemur
Quote:
Originally Posted by NCCoumbe
Why does it always seem like my oil pressure is high? I just did another oil change and it still stays as high as in this pic. Any ideas?
That's normal, mine runs that and a bit higher at speed.
10-09-2012 06:10 PM
NCCoumbe
High oil pressure?

Why does it always seem like my oil pressure is high? I just did another oil change and it still stays as high as in this pic. Any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC