Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Coolant Temp Gauge.

Join Wrangler Forum Today


Thread: Coolant Temp Gauge. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-16-2012 10:36 PM
Sea bass
Quote:
Originally Posted by 0III0forlife View Post
Which sending unit did you replace? There are 2 on your motor. The one that is up by the water neck where the thermostat is, that one is for the computer. The one you want to replace for the gauge is on the back side of the head in the drivers side rear corner.

The only way to replace the dash gauge itself is either replace it with a different gauge out of a YJ or replace all the gauges with aftermarket ones. The stock gauges get their signal from a circuit board, and there isnt any room in there to put an aftermarket gauge without taking out all of the other gauges, and the circuit board that powers them.
Thank you! Thak you!

I changed the drivers side rear (so pleased NAPA had one!) and all is well! I have a working temp gauge. It worries me not having it, especially off road in the dunes!
10-15-2012 09:53 PM
Sea bass
Quote:
Originally Posted by 0III0forlife View Post
Which sending unit did you replace? There are 2 on your motor. The one that is up by the water neck where the thermostat is, that one is for the computer. The one you want to replace for the gauge is on the back side of the head in the drivers side rear corner.

The only way to replace the dash gauge itself is either replace it with a different gauge out of a YJ or replace all the gauges with aftermarket ones. The stock gauges get their signal from a circuit board, and there isnt any room in there to put an aftermarket gauge without taking out all of the other gauges, and the circuit board that powers them.
I replaced the one by the water neck...well great, I will have a look tomorrow at the drivers side rear corner. Thanks!
10-15-2012 05:53 PM
jeff_in_rc I think it is a cluster BUT have you removed it and cleaned all of it's connections yet? I have read that this is a must do to older YJ's. My amp meter does not work and the temp guage is way off but I'm having too much fun to tear it apart! LOL

BTW if you do remove it disconnect the battery first!
10-15-2012 05:52 PM
0III0forlife Which sending unit did you replace? There are 2 on your motor. The one that is up by the water neck where the thermostat is, that one is for the computer. The one you want to replace for the gauge is on the back side of the head in the drivers side rear corner.

The only way to replace the dash gauge itself is either replace it with a different gauge out of a YJ or replace all the gauges with aftermarket ones. The stock gauges get their signal from a circuit board, and there isnt any room in there to put an aftermarket gauge without taking out all of the other gauges, and the circuit board that powers them.
10-15-2012 03:38 PM
Sea bass
Coolant Temp Gauge.

Can I replace the dash temperature gauge or do I have to replace the entire cluster? I replaced the sending unit, still not reading temps. I thought the send unit was the issue, when I turn the key, the temp gauge moves.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:02 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC