Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > Problems With Smittybilt

Join Wrangler Forum Today


Thread: Problems With Smittybilt Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-09-2013 10:00 PM
1jeeplvr Never have & now def never will buy from them.What some companies fail to understand is that if someone has a bad experience with them there are A LOT of avenues to go down now a days to let an awful lot of people know about it ie-forums,facebook etc.

That said a lot of people bash Q tec but they have always treated me fairly & Ive always had excellent customer service with them.
12-09-2013 05:33 PM
Dpilo22
ah smittybilt

I got an overhead storage console from them because I figured how could someone screw up such a simple thing? a bracket and tube clamps, that's it. Well I did the research before hand and found multiple install videos as well as read many threads. everyone said that from a crappy company this was one of the great products they didn't ruin. I ordered it. Package comes and has ALL of the parts it listed in the package. problem is that apparently the headliner I have for my bestop soft top gets in the way of the bracket. So I called smittybilt to find out where the bracket I saw in the install video is and the customer service guy was a complete jerk. I explained the situation and he asks if the parts listed on the invoice were in there and I said yes, then he says if it's there he doesn't understand what I want (already explained it to him). so I said, is there a way I can send him pictures so he can see what im talking about. He was so exasperated and acted like I was pissing him off. (this was the same guy as the original post, Mike P BTW). So I sent the pics and 3-4 hours later I call back and he sounds even more pissed that I called him back. So he asks me to go through it again and as I'm doing it he cuts me off with the phrase, "if you can stop talking so I can get a word in". Got my damn blood boiling but I kept my cool. Finally, after realizing I was dealing with someone who believes they are right 100% of the time I told him I would send him the video that shows the part and installation that I need. Called him back twice and been hung up on twice........
10-16-2013 08:02 PM
Shark_13 OP...that stinks for sure!
Not sure why though you didn't just go to Qtec right away though. Usually the fastest & less painful way to go about it.
10-16-2013 07:01 PM
ChasUGC I guess this is why people tend to replace the "m" with an "h" is their name.
10-13-2013 01:12 PM
JeepJT04 I picked these up from a scratch and dent for $65, glad I started reading these before I installed them.
07-29-2013 08:54 PM
JB52 Stuntz, I saw your post the day after I received my Sure Steps. Thanks for posting the great photos and the explanation. It made my life a lot easier installing them, knowing about the clearance issue. I made about an 1/8" clearance between the brackets and after driving a fairly washed out road with some twists and turns I heard a grinding noise under the driver's side. Not too bad, but I guess I'll have to take a little more off. Other than that, they look GREAT!
SHAME ON SMITTYBILT!!!!!!!
03-20-2013 08:56 PM
Stuntz Well it's been over 3 months of riding and the noise never came back. The grinding worked and I'm happy with the sure steps.
11-09-2012 11:53 PM
Stuntz I finally got around to grinding off some metal on that body to chassis mounting bracket that was contacting the Smittybilt Sure Step mounting bracket. I posted a pic below but now you can see a gap between the two pieces.

I guess the 2 things I would say to anyone installing these Sure Steps and having that horrible noise is to make sure these pieces aren’t touching and don’t torque the front bracket to the body any more than 18 ft*lbs. I think over torqueing may have made my problem worse.

So far it runs fine and there’s no more creaking noise. I’m glad these steps are going to work so I don’t have to drill any more into the body.



10-17-2012 07:37 PM
Stuntz I think I got it figured out but no thanks to Smittybilt. The front bracket was touching the body to chassis mounting bracket as shown in the picture below. When the vehicle would turn or hit a bump the body would shift slightly because of the stock rubber spacers between the body and chassis. When the chassis bracket would hit the Sure Step front mounting bracket this would act like a pry bar pulling on the bolts threaded into the body and causing that horrible creaking noise coming from below my feet. The sound completely went away when I loosened the bolts in the Sure Step front mounting bracket. I put a piece of tape and rubber in there for the meantime to prevent metal on metal clanking while the bracket was still loose.

Increasing the torque which was my first impulse only made the noise worse. I think I’ll keep the Sure Steps because I like the look of them and just grind a little off of the outer most edge of the body to chassis mounting bracket so I can see light between that and the Sure Step front mounting bracket. I’ll be sure to only remove metal beyond the bolt hole location and not compromise the bracket’s stiffness. A little black Rust-Oleum paint and she should be good to go!

It really annoys me that Smittybilt denies this has ever happened to anyone else. I don’t see how it couldn’t.

Well at least my Jeep sounds good again. It’s gonna be a good day tater!

10-17-2012 05:21 PM
Kota7x I had a similar problem but I went through 4 Wheel parts. I ordered some Smittybuilt Tube Doors for my TJ that would not fit up no matter what I tried. I drilled on the mounting holes, adjusted the hinges, the latch, anything I could do to get them lined up. They never did. I called 4WP and told them the story an they said bring them back and exchange them. Two weeks later I get some time to put them on. Same problem as before. Luckily 4WP also took back those doors and gave a refund.
10-17-2012 10:23 AM
WXman This is why I try to avoid "made in china" stuff whenever I can do so. Sorry to hear about your troubles.
10-15-2012 08:17 PM
Stuntz Joec361 - Hope you are still monitoring this post. Are you still hearing the noise after you took off the Sure Steps?

Wish I had read this first but I too bought some 3” Sure Steps from Smittybilt and I am having almost exactly the same problem. There is a horrible creaking noise coming from my driver side floor board when I hit a bump or turn a corner. It started less than a week after installing the Sure Steps. I believe the sound is coming from the front mounting bracket and maybe due to lack of clamping force from the bolts that replaced the factory bolts screwing into the body and fender reinforcement. See diagram below.


I called Smittybilt and talked to Ray who was supposed to be one of their head technicians. He said they have never heard of this issue happening if you can believe that. But he did recommend I torque the bolts in question to 18 ft*lbs. I checked it tonight and they were at least that much.

Another concern of mine is the original factory bolt threads were a little chewed up when I removed them so I don’t want to be changing out bolts any more than I have to. If my problem persists tomorrow I think I’ll take out the brackets and new bolts to replace the factory bolts but I worry that that won’t fix my problem. I’ve pretty much given up on the Sure Steps and just want to get my ride back in good working order. It sounds horrible now.

Any recommendations if the sound persists?
07-26-2012 02:34 PM
Malleyo22 Joec361- I recently put smittybilt 3" sure steps on my 05 TJ. Unfortunately I didnt ready this post prior to installation. I am having a serious squeak now as well. Did you have any torq recommendations with the install kit? (I did not) I thought I may have over tightened the bolts setting them at 45 ft lbs. I also used thread lock and cleaned all the areas- I just want to make sure I do everything I can to remedy this squeak before I have to deal with customer service for 3 months. Did you hear any feedback, from other posts or anywhere else, on if the new mounting hardware even worked?
03-08-2012 01:29 PM
joec361
Quote:
Originally Posted by Ichabod View Post
Sadly, delay and incompetence have become the norm for a lot of companies layely. I'm glad they remedied the situation, but three months of "DUH" can be frustrating.

I also learned to just call Quadratec in the beginning. This is the second post I've read about them clearing up a problem that wasn't really theirs to begin with.

Thanks for posting this up, another wrangler part manufacturer I will be avoiding in the future.
I applaud Quadratec for taking care of this issue for me. I buy the majority of the parts for my Jeep from them and I'll continue to do so.
03-08-2012 11:44 AM
Ichabod Sadly, delay and incompetence have become the norm for a lot of companies layely. I'm glad they remedied the situation, but three months of "DUH" can be frustrating.

I also learned to just call Quadratec in the beginning. This is the second post I've read about them clearing up a problem that wasn't really theirs to begin with.

Thanks for posting this up, another wrangler part manufacturer I will be avoiding in the future.
03-08-2012 11:43 AM
joec361
Quote:
Originally Posted by I8up View Post
joec361, maybe i will see you at topless on the beach, 19 May...Im in San Antonio
I live on Padre Island, so I'll be around for sure!
03-08-2012 11:40 AM
I8up joec361, maybe i will see you at topless on the beach, 19 May...Im in San Antonio
03-08-2012 11:06 AM
joec361
Quote:
Originally Posted by I8up View Post
Wow, I SUPPORT...No SmittyBilt...Hopefully someone in there Marketing Department Scans this forum...Sorry about your luck man, however, this is one of the very things that i find useful on this forum...SHARING INFO
I was pretty disappointed in them and how the situation played out. I'm with you. If nothing else, I hope someone within their organization will read this post so they can see what people are saying about them. Maybe they'll learn...maybe they won't. But either way, I'm done with their products.
03-08-2012 11:02 AM
I8up Wow, I SUPPORT...No SmittyBilt...Hopefully someone in there Marketing Department Scans this forum...Sorry about your luck man, however, this is one of the very things that i find useful on this forum...SHARING INFO
03-08-2012 10:35 AM
joec361
Problems With Smittybilt

I'm usually not the type to talk negatively about a company, but I feel pretty strongly about a recent negative transaction with Smittybilt. I'm pretty big on customer service, as I'm in sales myself. Being on the consumer side, I can definitely say I would never treat one of my customer's like this...and here's why. I apologize in advance for the long rant.

I purchased some 3" Smittybilt Sure Steps through Quadratec on December 27th. They came in about a week and a half later and I slapped them on my '05 Sport. A couple of days later, I noticed a pretty bad grinding/squeaking noise coming from the tubes. I sent an email into Smittybilt via their site to ask about this, but there was never a returned email or call.

I called in on January 27th to follow up. They said they never got my email, so I spoke with a Mike P. about the issues I was having. He asked what they could do to make me happy. I told them I would like to have the squeaking taken care of, or I can exchange them for the SRC Side Armor and I'd pay the difference. I attached pictures of the steps on my Jeep, along with the invoice from Quadratec. He said he was going to talk to his supervisor to see what they can do.

Didn't hear anything for a few days, so I followed up with an email on February 1st. He asked for my phone number (which is on my signature line on my work email that I've been emailing him from) so they can have it on file. I once again, gave him my number. He emailed me back and said he still hasn't talked to his supervisor and wanted to know if I had anything in mind to remedy the issue. I explained to him...once again...that I did everything I could - i.e. tightened all of the bolts, took the bolts off and put lock tight on them after cleaning both the surface of the brackets & the frame, etc. I told him this wasn't some small noise that only I hear. People in parking lots turn around and look when I'm driving behind them. He said he'll do everything he can to help me out.

Fast forward to February 10th. It's been a week and a half and I've yet to get a response from Smittybilt. I sent an email to Mike P. to check the status. I asked him if I needed to send them back to Quadratec and if I did, to please let me know quickly, so I don't miss the window on when they will take returns.

After no response from the February 10th email, I decided to call Mike P. at Smittybilt on February 15th. When I spoke to him, he asked me to give him a recap on my situation, as he didn't seem to remember me. He put me on hold for a few minutes, then gets back on to tell me his tech department has advised him to send me new mounting hardware. He said they've had some inquiries of this before and new mounting hardware seemed to remedy the noise. He asked me to email him the address I wanted the mounting hardware sent to, which I did that same day - February 10th.

Three weeks go by and the hardware never showed up. I ship and receive a lot of things at my job, so I know it takes time...but not that long. I'm finally fed up, so I send them an email on Tuesday (March 6th) saying that I've been patient throughout this whole process, but enough is enough. I sent them pictures of the invoice from Quadratec, as well as the steps on my Jeep. I told them I wanted a refund and I wanted these noisy steps off of my Jeep.

Once again, no email return or call back. So yesterday (March 7th) I forward the same email to Mike P. of Smittybilt asking him to advise on this matter ASAP, as this has gone on long enough. So finally, yesterday, Mike P. of Smittybilt responds to my email with this:
"Good morning Joe,

I apologize once again for your trouble. I just spoke with my supervisor once again in regards to the matter at hand.
We’ve come to the conclusion that this is one of those rare situations where the sure steps in question are making
a bit more noise than usual. If you feel that strongly about the circumstances of the matter, I would urge you to contact
Quadratec in regards to their terms and conditions upon return. Make them aware that we “Smittybilt” will issue them
“Quadratec” the necessary RA “Return Authorization” to assure that you are taken care of.
Once again I am sorry for the inconvenience and trouble, MP"

I called and spoke with Ian from Quadratec and forwarded him Mike from Smittybilt's email. Quadratec was totally cool with the situation and sent me a UPS label to send the steps back. They're going to give me credit after they get the steps back, and when they do, I'm going to get the Body Armor Rockcrawler Side Guards (http://www.quadratec.com/products/12053_402_07.htm ).

The worst part of this situation was I have the Smittybilt SRC front bumper and the matching rear bumper on my Jeep, which they were aware of. I told them that I've always supported them when people bash them on the forums, but I'm obviously done with that. I don't see how a customer that supports their products can be treated so poorly, with no regard for customer service.

I've thrown up my front and rear bumpers on craigslist, and it looks like I'll be selling both of those today. I'm done with having anything from Smittybilt on my Jeep and I will never buy anything from them again. Anyone who is thinking about buying something from Smittybilt, I would strongly urge you to spend the extra $20 or $30 for a product from another manufacturer who gives a damn about their customers.

Again, sorry for the rant, but I don't want anyone else to waste 3 months on a noisy part, only to be told to send it back in the end.

- Joe

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC