Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Simple Poll on Head Problem with Pentastar 3.6L

Join Wrangler Forum Today


Thread: Simple Poll on Head Problem with Pentastar 3.6L Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-01-2014 04:12 PM
Xena1
Quote:
Originally Posted by jj5079 View Post
Is this only a problem for the 2012? I have a 2013 and was wondering if I should be concerned.
If your engine build date is after July 26 2012, you are OK. That's when the engineering change was implemented.
11-01-2014 02:14 AM
Radioman I received a letter from Jeep dated 6/30/14 stating they were extending the warranty period to 10 years or 100,000 miles for 2012 and 2013 Wranglers for the left cylinder head.
11-01-2014 01:59 AM
jj5079 Is this only a problem for the 2012? I have a 2013 and was wondering if I should be concerned.
11-01-2014 01:27 AM
Radioman Left cylinder head replaced in May at 13,883 miles after throwing a code of P0306.

2012 model year.
11-01-2014 01:16 AM
blkunlmtd9 2912 JKU happened to mine in spring of '13 with around 30k mi on it
10-31-2014 05:47 PM
Ed Pursell 2012 JKU, 17,000 so far no issues. Built June 2012,picked up July 2012....
10-31-2014 02:56 PM
Godholio Feb 2012 build date, 41,000 miles, no problems (yet).
10-31-2014 12:43 PM
JerzyJeep
Tick-tock

I have 23K on my '12 Sahara JKU. No problems so far. ( Probably just jinxed myself. LOL )
10-29-2014 07:22 PM
just in joy Just dropped mine off yesterday Head issue and trans Lines fixing they say I will have it back by Thursday Friday this week. We shall See

No ticking in mine but the Check engine light has been on for a while I just did not have a chance to drop it off yet I am pushing 30k.

Mine has a Shifting issue stays in gear too long. and only shifts when I let off the gas
10-28-2014 05:53 PM
blackrubicon
Quote:
Originally Posted by Tseg View Post
My 2012 Rubicon built Dec '11 with 23K just went in for a new cylinder head. Happened the day before I was traveling out of the country... So it is at dealership while I'm in China... Hopefully all is fixed by the time I return at the end of this week.
My 2012 built in Dec 2011 went at 13k in March. Had replaced in May no issues.
10-28-2014 05:32 PM
pantoot Just over 18k miles and our check engine light came on. It's with the dealer now for a few day stay.
10-22-2014 11:33 AM
VansMudder Build date Feb 16/12, bought new March 15/12 has 27,500 kms on it and runs great.

If the head issue does occur I won't lose any sleep over it as Chrysler has extended the warranty on the 12's left head to 10 years or 240,000kms.
10-22-2014 05:11 AM
snobnk 2012 with 53000 miles and no problems yet...jinks?
10-22-2014 12:59 AM
Burrhead
Penestar V6 Head issue

Well i have a 2014 Rubicon X Unlimited.
6700 miles CEL light on, persistent cylinder #5. Waiting for the replacement head to come in. Just took it on 3000 mile vacation to Utah and back. We pulled into the driveway and the CEL came on. Dealership tried to tell me it was loose injector. Gave it back to me and the CEL came back on before I could even leave the parking lot. This is not how I wanted my first Jeep experience to go. Luckily bought lifetime warranty.
07-15-2014 05:29 PM
computeruser6 My 2012 Rubicon built in March 2012 at 31,000 miles still has no knocking. Only time will tell...
07-15-2014 04:39 PM
Tseg My 2012 Rubicon built Dec '11 with 23K just went in for a new cylinder head. Happened the day before I was traveling out of the country... So it is at dealership while I'm in China... Hopefully all is fixed by the time I return at the end of this week.
06-05-2014 11:02 AM
ElectricJay Took my Jeep into the dealership last month. CEL P0304 misfire cylinder 4. 23,000 miles. Jeep build 02/27/12. Tech performed leak down testing procedure and verified 155 PSI and 55% leak down on cylinder #4. They replaced left bank cylinder head and gasket set.
They had my Jeep for 2 LONG days and gave me a rental car. I wasn't having any problems with how it ran. After a month, it runs the same. No problem.
06-05-2014 10:57 AM
rdg04578 Looking at these results--31 percent have had an issue--glad I got a 13 and I would be wondering if I didn't have an issue yet--that number is huge
06-05-2014 10:20 AM
Bigalsjkru 21k on my 2013 JKRU with no issues but my wife's 2012 grand cherokee is in the shop getting heads and intake manifold replaced as we speak. Started running like crap then check engine light next thing I know she's out of a car with only 32k miles.
04-01-2014 09:22 PM
rubi2012
Head problem poll

2012 Rubicon has had slight ticking at start up only since new. 26k and CEL came on and dealer confirmed head replacement required. She never ticked bad and always ran great, hoping this will be the only head issue.
10-29-2013 10:09 PM
BrokeRugger Cel came on right around 32k. Head is being replaced now. 2012 2dr Sahara received 11/2011.
10-29-2013 07:27 PM
knav I just turned 12000 on my 2012. After reading this, I guess I need to listen to my motor. I've had no check engine light though.
10-29-2013 07:11 PM
basecamper 2012 JKUR 13K miles has ticked loudly since day one took in today to have CEL checked they kept it and are replacing the head.
10-29-2013 07:06 PM
geckojk1 27000 kms on stockers no cel yet built 6/12 knock on wood and not in cylinder head
10-29-2013 06:57 PM
Xena1 Just wait. All AA heads will end up in the scrap pile. Just my $.02
10-29-2013 04:22 PM
TMO44 My 2012 Rubicon has 10k on it now and the engine ticking started around 6k. I figured I would wait till all the Chryler/Dealer/Customer argueing was done so that I only had to go in once to get the issue resolved. Dealer replaced
Now my Jeep is back at the dealer after driving it for 200+ miles and the tick is louder than before. Dealer has had it 2 days and claims they do lifters/rockers and garunteed me the noise would not come back. On a side note when I picked it up the dealer told me they went ahead and took care of the recall for the power steering line replacement. When they took the line off fluid poured all over the frame, taking my rustproofing and frame paint off. They thought it would be good as new with a spray can of undercoat....wrong!!!not hear anything abnormal about the engine and the ticking that I am hearing is from the injectors.
Also, is anyone having trouble getting a loaner car from their dealership? I was first given a Dodge Caliber that reaked of smoke so bad I got a headache. Now the second time back in the shop I am given a PT Cruiser with 70,000 miles and the spoiler ripped off the top.....

I am a big Jeep fan and Chrysler supporter but this may be my last Chrysler product and for sure last trip the that particular dealership.
10-15-2013 12:11 PM
wesleyfrncs I know i dont have a 3.6 but my 2010 with 18k miles just had to have its head changed
09-13-2013 05:04 PM
ikeymay 20k miles on mine and it just went into the shop this morning for a check engine light. code was misfire on cylinder 4. updated computer and reset. engine light came on again ten miles later. now it's gonna be at the dealership for who know how long, because the head is on national back order due to high demand. my dealership has done "six or seven" left head replacements on pentastar engines, so far. it is, they told me, a "know issue with these motors". this sucks. I mean, you buy a new rig to avoid this kind of problem, right? she-it!
07-24-2013 09:20 AM
wat3rdog 8,500 mi on a 13 built last Oct. Knock on wood problem free.
About 2,400 have been highway road trips and 1/3 or so for 4x4.
Climbing the steep grades around Needles Ca on I-40 the eng temp climbed to around 3/4 on the gauge a few times but would cool back down on the down grade. Very happy so far.
I bought her last Dec.
07-24-2013 09:19 AM
Rabuck Had mine replaced about 19,000 miles and now have over 23,000 no problems yet
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:14 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC