Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Simple Poll on Head Problem with Pentastar 3.6L

Join Wrangler Forum Today


Thread: Simple Poll on Head Problem with Pentastar 3.6L Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-15-2014 04:29 PM
computeruser6 My 2012 Rubicon built in March 2012 at 31,000 miles still has no knocking. Only time will tell...
07-15-2014 03:39 PM
Tseg My 2012 Rubicon built Dec '11 with 23K just went in for a new cylinder head. Happened the day before I was traveling out of the country... So it is at dealership while I'm in China... Hopefully all is fixed by the time I return at the end of this week.
06-05-2014 10:02 AM
ElectricJay Took my Jeep into the dealership last month. CEL P0304 misfire cylinder 4. 23,000 miles. Jeep build 02/27/12. Tech performed leak down testing procedure and verified 155 PSI and 55% leak down on cylinder #4. They replaced left bank cylinder head and gasket set.
They had my Jeep for 2 LONG days and gave me a rental car. I wasn't having any problems with how it ran. After a month, it runs the same. No problem.
06-05-2014 09:57 AM
rdg04578 Looking at these results--31 percent have had an issue--glad I got a 13 and I would be wondering if I didn't have an issue yet--that number is huge
06-05-2014 09:20 AM
Bigalsjkru 21k on my 2013 JKRU with no issues but my wife's 2012 grand cherokee is in the shop getting heads and intake manifold replaced as we speak. Started running like crap then check engine light next thing I know she's out of a car with only 32k miles.
04-01-2014 08:22 PM
rubi2012
Head problem poll

2012 Rubicon has had slight ticking at start up only since new. 26k and CEL came on and dealer confirmed head replacement required. She never ticked bad and always ran great, hoping this will be the only head issue.
10-29-2013 09:09 PM
BrokeRugger Cel came on right around 32k. Head is being replaced now. 2012 2dr Sahara received 11/2011.
10-29-2013 06:27 PM
knav I just turned 12000 on my 2012. After reading this, I guess I need to listen to my motor. I've had no check engine light though.
10-29-2013 06:11 PM
basecamper 2012 JKUR 13K miles has ticked loudly since day one took in today to have CEL checked they kept it and are replacing the head.
10-29-2013 06:06 PM
geckojk1 27000 kms on stockers no cel yet built 6/12 knock on wood and not in cylinder head
10-29-2013 05:57 PM
Xena1 Just wait. All AA heads will end up in the scrap pile. Just my $.02
10-29-2013 03:22 PM
TMO44 My 2012 Rubicon has 10k on it now and the engine ticking started around 6k. I figured I would wait till all the Chryler/Dealer/Customer argueing was done so that I only had to go in once to get the issue resolved. Dealer replaced
Now my Jeep is back at the dealer after driving it for 200+ miles and the tick is louder than before. Dealer has had it 2 days and claims they do lifters/rockers and garunteed me the noise would not come back. On a side note when I picked it up the dealer told me they went ahead and took care of the recall for the power steering line replacement. When they took the line off fluid poured all over the frame, taking my rustproofing and frame paint off. They thought it would be good as new with a spray can of undercoat....wrong!!!not hear anything abnormal about the engine and the ticking that I am hearing is from the injectors.
Also, is anyone having trouble getting a loaner car from their dealership? I was first given a Dodge Caliber that reaked of smoke so bad I got a headache. Now the second time back in the shop I am given a PT Cruiser with 70,000 miles and the spoiler ripped off the top.....

I am a big Jeep fan and Chrysler supporter but this may be my last Chrysler product and for sure last trip the that particular dealership.
10-15-2013 11:11 AM
wesleyfrncs I know i dont have a 3.6 but my 2010 with 18k miles just had to have its head changed
09-13-2013 04:04 PM
ikeymay 20k miles on mine and it just went into the shop this morning for a check engine light. code was misfire on cylinder 4. updated computer and reset. engine light came on again ten miles later. now it's gonna be at the dealership for who know how long, because the head is on national back order due to high demand. my dealership has done "six or seven" left head replacements on pentastar engines, so far. it is, they told me, a "know issue with these motors". this sucks. I mean, you buy a new rig to avoid this kind of problem, right? she-it!
07-24-2013 08:20 AM
wat3rdog 8,500 mi on a 13 built last Oct. Knock on wood problem free.
About 2,400 have been highway road trips and 1/3 or so for 4x4.
Climbing the steep grades around Needles Ca on I-40 the eng temp climbed to around 3/4 on the gauge a few times but would cool back down on the down grade. Very happy so far.
I bought her last Dec.
07-24-2013 08:19 AM
Rabuck Had mine replaced about 19,000 miles and now have over 23,000 no problems yet
07-24-2013 08:12 AM
AlaskanJeep 13k on my 2013. No issues yet
07-24-2013 08:11 AM
guitargeek76 Hope you don't me voting, though I only have 11,987 miles on my JK. I don't have a pinging or ticking, but I do have a stuck valve. Bringing her in Monday for the replacement.
05-27-2013 09:27 AM
BigManAndy 13,500 miles and still on the stock heads on my 2012.
05-27-2013 08:50 AM
COStrider 35,000+ and no head issues on my 2012
05-27-2013 07:49 AM
4DoorCrush
Quote:
Originally Posted by Martin10 View Post
I recently test drove several 2013's before buying mine. One of them had an obvious tapping sound. Passed on that one.
Don't think there has been any 13 with confirmed head problems
05-27-2013 07:48 AM
4DoorCrush 12534 on mine
05-27-2013 07:41 AM
floridawrangler91 2012 JKU Sport - 38,000 miles - no problem (knock on wood ...)
05-27-2013 06:43 AM
Martin10 I recently test drove several 2013's before buying mine. One of them had an obvious tapping sound. Passed on that one.
05-27-2013 01:13 AM
wat3rdog 5700 and fingers crossed
05-27-2013 01:10 AM
DiSH Almost 22,000 miles and still no issues.
05-26-2013 06:44 AM
Mcruse I have 8500 miles and no problems yet.... Knock on wood.
02-03-2013 09:49 PM
Steady I have a 2012 JKU rubicon with 33k on it, and havent had the engine light turn on or any idleing/power problems... i have noticed a slight ticking sound but like someone else said i just figured it was the way the 3.6 sounded and never gave it anymore thought till reading this thread lol thanks guys... Could there be a head problem without throwing the check engine light?? i guess im going to have to pay more attention to it now and go from there...
02-03-2013 08:25 PM
wat3rdog I have a 2013 JKUR built in October of 12. I just noticed a noticed a noise coming from the passenger side of the engine. It sounds like I'm hearing the lifters and I can here it from behind the front passenger wheel with the hood closed and better with the engine beauty cover off. I just got back from a 500 mi road trip with no issues until after grabbing a bite noticed it had a bit of a diesel 4cyl sound. Any thoughts on my issue would be greatly appreciated. She has 2,223mi. on her.
01-03-2013 08:17 AM
KittyPrawn
Quote:
Originally Posted by Mntdriver View Post
Exactly. This is so stupid. A poll from a guy who doesn't even own a Jeep.
He did end up buying the Jeep and the poll had been relevant to this. He last bumped it in October. Ya'll are the one necro-ing this nonsense only to whine about it.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:47 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC