Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 89 YJ Tranny Problems

Join Wrangler Forum Today


Thread: 89 YJ Tranny Problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-10-2008 12:40 PM
87YJWrangler yep always willing to help a fellow jeeper
12-10-2008 12:36 AM
beasst95 I know when 4L is being used i can shred stuff up when going really fast speed. But this was steep hill and some what rock crawling when 4L it was used on. Right now the jeep is on jack stands and still trying to figure out what the problem is.
But Thanks for the input.
12-09-2008 11:37 PM
87YJWrangler Maybe you seized up your trans case I heard from my dad who has had trucks since he was 16 that running any 4wd in 4L on pavement is a bad move it can shred your transfer case and lock up your gears to the point of your not gonna get them to move with out destroying something
12-09-2008 04:39 PM
beasst95
89 YJ Tranny Problems

Hello guys,
I need some help trying to figure out tranny problems. Two weeks ago I flat tow my jeep,with all in Neutral. When I got to place, trans oil coming from under car. I check everything and it was OK, thru out the drive I felt slipping on 4L and 4H. I made it OK, but on way back driving on 2H I could not go past 10 mph. I towed back home, I pull pan down and metal shavings on pan. ( Tranny out) I got replacement from another 89 YJ. I swapped out trans with the same Torque Conv, but it did not fit properly.I had to use the one that came with the one I bought. Good fit, after installing everything back together my T-case is stuck on 4L and trans won't engage, no diff spins. I far as I know my YJ is an 89 w/ 4.2 L and auto trans (TF999) and everything seems to be stock.
Thanks guys for your help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC