Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Help!

Join Wrangler Forum Today


Thread: Help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-21-2012 10:29 AM
jksport12 Sounds like the clutch went. If it won't engage. You can try power shifting to see if its the tranny but i doubt it. A clutch has a distinct smell to it. Like metal burning. I blew out my clutch in my car a few years ago. Smelled the burning then wouldn't engage. Towed it to the shop. Replaced clutch and flywheel. Good as new after that.
10-21-2012 10:11 AM
SpartanX13X
Quote:
Originally Posted by SpartanX13X
There is no movement at all, the RPMs
Do go up, sorry I'm at work and on my phone that's why there might be some mistakes
10-21-2012 10:10 AM
SpartanX13X There is no movement at all, the RPMs
10-21-2012 01:13 AM
Derp
Quote:
Originally Posted by SpartanX13X
Last week i bought my first wrangler, a 99 sport with a 5 speed, i am fairly new to driving stick, but i am also pretty good at it, but the 3rd time that i was out driving it since i got it i noticed a burning smell (from reading other threads i'm thinking it is the clutch) (i'm also 18 and fairly new to cars)then the check engine light came on and it ended up being the O2 sensor. i told my dad about it and he said not to worry and be careful. i drove it 6 other times since then and 4 out of the times the burning smell came back. Also the last 3 times of those 6 i had some problems shifting into 4th and 5th gear. so tonight i was changing the O2 sensor and oil, and i wanted to drive it around and see if the light went out and i started having trouble shifting into 3rd, so i got it home then my dad wanted to drive it around to make sure there was something wrong and it wasn't me. well we pulled out of my driveway then onto the main road then when my dad went to put it into 2nd i wouldn't go. we turned down the next street and we stopped. it wouldn't go into gear, we were there for 10 min trying to get it into gear, i ended up having to push it and we were finally ably to get it into first, we were able to get it home and i don't know what happened.
Can someone please tell me what might have happened i think its either the clutch or the transmission but i don't know how to check, any tips would be helpful.
Thanks
Clutch. With it in gear and the clutch in get on the gas and see if you get any forward movement. Or when driving in 3rd or 4th floor it and see if the rpm's rise more than usual.

How does the clutch feel? Is the pedal firm or soft? How's the fluid level?
10-21-2012 12:07 AM
SpartanX13X
Help!

Last week i bought my first wrangler, a 99 sport with a 5 speed, i am fairly new to driving stick, but i am also pretty good at it, but the 3rd time that i was out driving it since i got it i noticed a burning smell (from reading other threads i'm thinking it is the clutch) (i'm also 18 and fairly new to cars)then the check engine light came on and it ended up being the O2 sensor. i told my dad about it and he said not to worry and be careful. i drove it 6 other times since then and 4 out of the times the burning smell came back. Also the last 3 times of those 6 i had some problems shifting into 4th and 5th gear. so tonight i was changing the O2 sensor and oil, and i wanted to drive it around and see if the light went out and i started having trouble shifting into 3rd, so i got it home then my dad wanted to drive it around to make sure there was something wrong and it wasn't me. well we pulled out of my driveway then onto the main road then when my dad went to put it into 2nd i wouldn't go. we turned down the next street and we stopped. it wouldn't go into gear, we were there for 10 min trying to get it into gear, i ended up having to push it and we were finally ably to get it into first, we were able to get it home and i don't know what happened.
Can someone please tell me what might have happened i think its either the clutch or the transmission but i don't know how to check, any tips would be helpful.
Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC